Airplay problems

Tagged: 

This topic contains 5 replies, has 2 voices, and was last updated by  Heiner Moderator 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • 19. November 2016 at 18:30 #24025

    I have a few things that I have observed!

    1. If I by Squeezebox have played a few numbers and then switch on airplay from an Iphone or Ipad, I get no connection to M2P! I have to reboot to get it working.
    2. If I have airplay running from my Ipad and “Switch off” for airplay and try to connect from my iphone, it says that another device is connected! Reboot of M3P is necessary for it to work.
    3. When I play music via airplay, my rotary encoder does not work. If I turn the encoder the music stops. It looks like I still have a connection to M2P, but it does not help to disconnect and reconnect again. I have to reboot M2P to get it working again.

    regards Bjarne

    29. November 2016 at 12:55 #24308

    Hi bjarne,
    You might want to try out the automatic switch for Squeezelite and Shairport, detailed in our Top 5 Tweaks article: https://www.max2play.com/en/2016/11/top-5-tweaks-for-the-optimal-max2play-setup/
    Regarding your other issues, please try to detail your steps you have taken so far and your setup so we can help you more accurately.

    3. December 2016 at 23:42 #24529

    Hi Heiner

    Thanks for your help.

    1. I found out what was wrong when switching between Squeezebox and Airplay. The case is that I use HW volume and when I’m playing Squeezebox I play with a Master volume setting = 25. When I use Airplay the volume has to be almost 100 on airplay device to hear anything. Then I have to turn Master volume up to 35 to hear airplay.
    Now the problem is that when I go back to play on Squeezebox I have to remember to turn down the volume to 25 to avoid blowing off my speakers!
    Can I make so that airplay is using HW volume too?

    2 and 3. I checked the “Enable I2S-MMAP (Mixerdevice for Soundcards)” i Raspberry settings and that made the trick:o).

    best regards
    Bjarne

    13. January 2017 at 17:42 #25894

    Hi bjarne,
    Yes, this should work, shairport also has command line options in the Audioplayer menu. Try it out!

    17. January 2017 at 21:19 #26010

    Thanks Heiner

    I tried the same settings (-o hw:CARD=IQaudIODAC -V Digital -Q) in Shairport command line option, but it don’t like the “-o” parameter!

    Actually these commands says nothing to me. I’m not very good at commandline programming and linux:(

    regards Bjarne

    20. January 2017 at 15:18 #26160

    Hi bjarne,
    Please try this command:
    volume_range_db=dBvalue;
    Set this dBvalue to use just a portion of the full range of
    attenuation offered by a mixer. For example, if a mixer has a
    minimum volume of -80 dB and a maximum of +20 dB, you might wish
    to use only 60 dB of the 100 dB available. This might be because
    the sound becomes inaudible at the lowest setting and unbearably
    loud at the highest setting — indeed, many domestic HiFi
    systmes have a volume copntrol range of just 60 to 80dB. Another
    potential use might be where the range specified by the mixer
    does not match the capabilities of the device. For example, the
    Raspberry Pi’s DAC that feeds the built-in audio jack claims a
    range of 106 dB but has a useful range of only about 35dB. The
    setting allows you to specify the maximum range from highest to
    lowest. The range suggested for the Raspberry Pi’s built-in
    audio DAC, which feeds the headphone jack, is 35. Using it in
    this case gives the volume control a much more useful range of
    settings. If you omit this setting, the full “native” range of
    the mixer is used.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

Register here