[SOLVED] After Kernel upgrade to 4.9 on RPi 3 Max2Play 2.41 claims: No Raspberry Pi

Max2Play Home Forums Max2Play on Raspberry PI [SOLVED] After Kernel upgrade to 4.9 on RPi 3 Max2Play 2.41 claims: No Raspberry Pi

Viewing 13 posts - 1 through 13 (of 13 total)
  • 25. Februar 2017 at 21:24 #27227

    Upgraded Linux kernel on my Raspberry Pi 3 B as per: https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=167934

    pi@HifiBerry:/ $ uname -a
    Linux HifiBerry 4.9.11-v7+ #969 SMP Mon Feb 20 12:55:08 GMT 2017 armv7l GNU/Linux

    Max2Play Web interface claims:
    This function is for Raspberry Pi ONLY! It seems, that you do not have a Raspberry PI.

    Top right-hand corner states:
    Version 2.41

    Apart from that everything works as expected!

    27. Februar 2017 at 15:22 #27267

    Hi tezet

    Please try to upgrade the kernel using our web-interface, by Raspberry settings and click on upgrading the kernel.

    Mohammad Mbydeen

    27. Februar 2017 at 16:15 #27275

    Hi Mohammad,

    The webinterface refuses to do the upgrade with the message: This is only available on a Raspberry PI.
    The page with raspberry settings isn’t functional anymore after the manual upgrade;
    No audio-card selection and no debug-information with config.txt.

    As stated earlier; The rest of the player works as expected.



    27. Februar 2017 at 16:37 #27285

    Hi tezet

    Please try to burn new image and make sure that you are using the latest version of Max2Play, which is 2.41. and then try to upgrade the kernel.

    Mohammad Mbydeen

    1. März 2017 at 19:11 #27381

    Hi Mohammad,
    I burned the new max2play 2.41 image.
    Updating the kernel through the max2play webinterface only updates the rpi firmware to 4.9-y.
    It does not upgrade the raspbian kernel which is still at version 4.4.41-v7+

    I’d like to upgrade the kernel to 4.9 since it brings improvements to audio and to the sd-card drivers.


    2. März 2017 at 15:48 #27410

    Hi Tezet

    That sounds strange !! Please make sure to reboot the device after you update the kernel.
    Maybe there is a bug in the installer that used accidentally 4.9

    Mohammad Mbydeen

    2. März 2017 at 22:57 #27417

    Off course I rebooted it 🙂
    After the reboot I tried Upgrade Kernel again and received the message; no updates.
    And the Kernel is still on 4.4.41-v7+

    On the previous image I did exactly the same; I then went in using ssh and upgraded the kernel from the command-line using: sudo BRANCH=next rpi-update
    After the reboot the max2play Raspberry Settings webpage stated: This function is for Raspberry Pi ONLY! It seems, that you do not have a Raspberry PI.
    All the other pages work fine, as does my HifiBerry Digi+ Pro

    5. März 2017 at 18:14 #27452


    I could reproduce this behaviour.
    The webinterfaces kernel-updater is interrupted by the safety question about the driver compability since the 4.9 kernel is in the master branch of rpi-update.
    If I run rpi-update via ssh an answer the safety question everything runs fine – but max2play doesn’t recognise the PI3 anymore (just BCM2835) and settings are locked as described above.

    I could get my new Zero W working with just a „dist-upgrade“ so I could resign ugrading the kernel to 4.9.

    The Zero W is working nicely so far with the 4.4 kernel, but an upgrade would be nice. The recent image doesn’t support rpi-update (has to be upgraded?) on the Zero W and obviously the WiFi drivers are missing in the recent 2.41 image too – a dist upgrade on a PI3 did solve this problem for me.

    So long it’s a litlle bit more complex to get the Zero W working – hoping for a new image with all the driver packet already included an maybe support for the new kernel 🙂

    6. März 2017 at 11:22 #27457

    Thank you Bort for sharing those information.

    Mohammad Mbydeen

    7. April 2017 at 23:18 #28032

    Upgrading to Max2Play 2.42 fixed the issue!

    10. April 2017 at 11:27 #28043

    Hi tezet

    Good to know that your problem has been solved.

    Mohammad Mbydeen

    1. August 2020 at 4:02 #49484

    I am getting the same error with my RPi4 8Gb using HiFiberry DAC+ DSP running m2p 2.52.

    After updating/upgrading via the web interface, I can not make any selections on this page. I had to reinstall the image and not make any OS/Kernel updates to keep functionality of this page.

    I am hoping this helps to troubleshoot in future RPi4 builds. Thanks for all your help and development of this great product.

    Update: I updated everything using SSH and disabled the RPi Bluetooth settings using the CLI which works for now.

    4. August 2020 at 12:02 #49495

    Hi Chris,

    Thanks for the note. Of course, kernel updates can always cause problems. So far we have not been able to test our software with the 8GB Pi. We therefore do not recommend doing kernel updates manually for now. If important functions are included in future kernel updates, we will add them to our image.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

Register here