Accesspoint works but will not save login details

Max2Play Home 2016 (en) Forums Max2Play Add-ons Accesspoint works but will not save login details

This topic contains 11 replies, has 2 voices, and was last updated by  alex premium 2 years, 2 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • 24. Juni 2018 at 14:52 #36335

    Hi all,
    After working on several problems setting up and using the access-point module using Kodi, I’ve got it working but when I shut the M2P down and go back to it and fire it up, the only way I can get it to work is to reboot M2P and use the „connect without internet“ option. When I’ve done that I have to go into Kodi and make it forget it’s last connection and then do a rescan to refind the M2P.

    A normal router would remember the connection, so I’m hoping I’m not setting things up as they should be.

    So my question is, is this normal, am I missing something, can I tweak something to make them just connect up without too much hassle.?

    Has anyone experienced the same and hopefully found a „fixit“
    Thanks

    • This topic was modified 2 years, 3 months ago by  alex.
    • This topic was modified 2 years, 3 months ago by  alex.
    • This topic was modified 2 years, 3 months ago by  alex.
    25. Juni 2018 at 16:02 #36351

    Hi alex,

    I’m not sure I get your setup.

    If you want Max2Play without internet and only use it for Kodi, you would not even need an access point, just need to set Kodi to autostart and it should be displayed via HDMI once you start it, right away.

    If you want to use an access point, you need the access point setup and set it to standalone after installation.

    25. Juni 2018 at 17:05 #36359

    Hi Heiner

    My system is a standalone system. I have a M2P with the access point module installed hooked up to a 2TB hardrive.
    This setup also has Kodi running on it that boots up automatically

    There are no wired connections to the M2P except power and the lead to the 2TB hardrive from the Pi

    When I power it up, I access the files using my phone’s WiFi and the Kode app which is installed on my phone and this uses the access point, to get access to the pi/M2P

    I’m not or can’t use hdmi in the way I need to use it, it has to be a true standalone unit also without a router, which as you have said that’s the whole point of the access point

    That’s how I’m running it but recently it’s developed another Fault where Kode finds it, but when it does it disconnects the access point for some strange reason
    Hope this makes sense now , maybe I have missunderstood how your project worked, if so my apologies, I thought it was a true standalone system controlled wirelessly using a Kodi app
    A

    26. Juni 2018 at 16:29 #36369

    Hi alex,

    Thanks for clarifying, that’s mostly the same setup as most standalone Max2Play systems, except the Kodi integration is usually only used for videos and Squeezelite, Shairport or MPD player used for audio, depending on what you need. If you have iOS I would recommend Shairport, if you have android I would recommend the Squeezebox Server (install with internet access) with Squeezelite.

    26. Juni 2018 at 16:55 #36372

    Hi Heiner

    This is really helpful.

    I have Android,
    So are you saying install Squeezebox server by connecting it to the internet, then install Squeezelite on my android phone to control Squeezebox?

    Sorry for sounding unsure but I just want to make sure I understand so that I know I’m doing the right things.
    And once again Heiner, I really appreciate the great work you do and your ongoing invalid help.
    Thanks

    27. Juni 2018 at 9:55 #36382

    Hi alex,

    Thanks for the kind words.

    Squeezelite is pre-installed on all max2play systems, but you need to install Squeezebox Server. After, you can control the headless Squeezelite from any Squeezebox app, with DLNA apps or if shairtunes2 is active also with AirPlay.

    27. Juni 2018 at 13:09 #36383

    Hi Heiner
    Thanks for the reply and advice. I’ll hopefully try this in the next few days.
    Really appreciate your help
    BW

    27. Juni 2018 at 13:09 #36384

    Hi Heiner
    Thanks for the reply and advice. I’ll hopefully try this in the next few days.
    Really appreciate your help
    BW

    2. Juli 2018 at 21:08 #36439

    Hi Heiner

    Just realised that my last posting isnt showing so I’ll try again.

    The instrcutions you gave me did work, so that was a big improvment from where I was. However, when I came and recconnected with my phone to M2P, it just would’nt connect. Or it did then dropped the connection.
    Now it says its obtaining the ip address and just stays like that for about a minute then says IP configuration problem, then drops out.
    I did burn another image and it did much the same, so I tried using my ipad to connect and that just did nothing at all, I just saw the spinning disc showing that it was trying to connect but thats about it.
    And when it is connected and working properly I have noticed that I don’t get an explination „!“ by the side of the wifi indicator on my phone, when it drops out it does not loose wifi, but the explination „!“ appears and I cant access my music.
    It also does not show all of the artwork, just some
    I hope this makes some sense Heiner.
    Any ideas why and how I can fix it.

    Since my last posting, I have tried several things to try and stop M2P from loosing its connection. If you remember when I first connect to the accesspoint with my Android phone, I’m presented with the M2P main GUI to enable me to sign in. I hit the three top righthand dots and pick „Use this network as is“. My wifi says the accesspoint is connected….
    When I have done this I open Squeezer and it finds all my music. However within 2-3 minutes, I see a „!“ on my wifi signal indicator on my phone and now the wifi says „connected no internet“. Once I get this, squeezer does not work, I can’t find my music and I have to either do a complete reboot on both the Pi and Squeezer, OR, go to the M2P GUI page and pick „use this network as is“ and reboot squeezer.
    To test things out, I have burned new images, connected M2P to a Hootoo travel router then connected my android to that, and used M2P that way, I’ve also used another android, an ipad and iphone, every way I have tried to make this work, but the same thing happens all the time. And now I am convinced its M2P that is breaking the connection. Can someone Please help and offer some hope of ever getting this working..I first tried this 2 years ago, and still no further on. Please help.. Thanks

    • This reply was modified 2 years, 2 months ago by  alex.
    • This reply was modified 2 years, 2 months ago by  alex.
    • This reply was modified 2 years, 2 months ago by  alex.
    12. Juli 2018 at 9:30 #36549

    Hi Heiner,
    Thanks for your suggestions and hlep but I think I have resolved my problems. So I’d like to put a RESOLVED in the heading of this string to help anyone else who might be having the same issues.

    To recap my problem….

    I could’nt connect or keep connected to the accesspoint on my m2p.

    The reason why I could’nt connect to it was because the wifi on my m2p had somehow been damaged so I could not connect over the wifi, BUT I could see it using wifi and connect to it via the ethernet port. It was’nt until I tried other Pi’s that I was able to work this out because you would have thought if you can see the wifi it has to be working..Not in my case.

    But the main problem of connecting to my m2p and then loosing the connection was resolved by turning ON the aeroplane mode before connecting to the accesspoint. Im not sure if you should have to do this, but it worked on 4 different Pi’s.

    This also works works with my Ipads, Iphone4 which I use ALL the time as the remote controller in my car. It also works with with both of my MOTO5G phones.

    There is a BUT….Its a bit clunkey, so please read below to see how I did it.
    ( BEFORE YOU START REMEMBER TO UNPLUG YOUR ETHERNET CABLE TO YOUR ROUTER IF YOU HAVE IT CONNECTED)

    For iphone4, which may not be the same for newer models, once you have found the accesspoint after turning on aeroplane mode, you connect to it. When you do, a homepage will load up, if you are using an Iphone4, you have to hit the CANCEL top right of the screen before the homepage loads. When you have managed to do this, and the timing is critical, you are given an option to „use without internet“, hit that. Then open your controller, in my case on my iphone its the LMS player and it should find your player.

    Using Android, in my case MOTO5G, as above to connect to the accesspoint, however, you have to wait for the homepage to load FULLY. When its loaded, hit the three buttons top right and, then hit „use this internet as is“, then load your player, in my case its Squeezer for my andriod phone.

    Both the above options work for me all the time, but there does seem to be issues if you have a problem connecting, for example, I could’nt connect yo my player was already open when trying to connect to the accesspoint. So its a clean boot each time. I have not spent much time trying to find out why this happens (yet :-)) and it has only been on my android. But for me, I’m a happy chappy again.
    Hope this helps someone, good luck.

    13. Juli 2018 at 14:56 #36572

    Hi alex,

    Sorry about the late reply, I was on holiday and your current post required a little more attention, so it got oushed back a little.

    I am happy to hear, you found a solution and thank you for detailing your process here. 🙂

    I will mark this topic as solved to let other users know about the status of the discussion.

    13. Juli 2018 at 17:54 #36585

    Hi Heiner
    Hope you had a great holiday and no problem whatsoever about the slight delay. But once again thanks for your help and guidance into pushing me into the right direction
    A

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

Register here