Accesspoint with bridged mode and maybe some more options?

Max2Play Home 2016 (en) Forums Max2Play Development (Ideas, Wishes) Accesspoint with bridged mode and maybe some more options?

This topic contains 4 replies, has 2 voices, and was last updated by  Mbydeen 5 months, 1 week ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 6. April 2017 at 12:14 #28009

    Connected to Max2Play Accesspoint, I cannot see my airplay devices anymore. Even that on max2play.

    I normally use hostapd with a bridge configured in etc/network/interfaces which is working well, but max2play uses iptable routing instead. So this is not the right way.
    Maybe you can provide a simple solution to that way to get bridged mode also and bring that to plugin?

    A configuration of band 2.4 or 5 GHz (e.g. for external wlan sticks) and maybe channel would also help.

    kind regards
    michael

    6. April 2017 at 14:23 #28012

    Hi mtk

    If you configured the access point and the Shairport on the same device , there is no problem. access-point plugin and Shairport could work simultaneously, and if you setup the access-point plugin on one device and the shairport device on another one, make sure to check the “Standalone” checkbox on the access-point.

    And as I mentioned in the comments sections on our webpage, we could have the WLAN bridged mode feature in the future.

    Regards,
    Mohammad Mbydeen

    6. April 2017 at 20:55 #28020

    Hi Mohammad
    after reboot I could see that shairport device on m2p from my iphone 🙂
    but not the other shairport-sync installations on my other raspians.
    “Standalone” seems not to be an option to my setup here at home, because I got problems on mounting nfs(lost my mp3 for MPD). So i will try to modify network/interface and add a bridge there.
    Are you expecting any conflicts within m2p setup? Did not complete went throug this …
    Need some workaround until m2p supports bridged mode …

    kind regards
    Michael

    4. May 2017 at 15:43 #28706

    Just for info:

    meanwhile I tried to add a bridge to max2play manually like on raspian jessie:

    /etc/network/interfaces:

    
    auto lo
    iface lo inet loopback
    iface eth0 inet dhcp
    
    # WLAN
    # auto wlan0
    # allow-hotplug wlan0
    iface wlan0 inet static
    address 192.168.2.1
    netmask 255.255.255.0
    
    auto br0
    iface br0 inet dhcp
    bridge_ports eth0 wlan0
    gateway 192.168.1.xxx

    and adding the bridge to hostapd.conf:

    # Bridge-Betrieb
    bridge=br0
    # Ländercode
    country_code=DE
    interface=wlan0
    ...
    

    The result was somehow instable. After installation it was running fine, after reboot the problems started.
    So I fear that I do not know enough of max2play architecture and its services an their startup mechanisms so far.
    I suppose, that during startup some network configuration is done my max2play that will cause the problems, maybe …

    11. May 2017 at 14:26 #28792

    Hello mtk,

    Thank for your contribution to the forum, and we hope that we could find a common ground for cooperation with you to work on Max2Play related projects in the future.

    Best Regards,
    Mohammad Mbydeen

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here