Accesspoint and Bluetooth

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Accesspoint and Bluetooth

This topic contains 21 replies, has 2 voices, and was last updated by  MarioM Moderator 4 months, 1 week ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • 18. April 2020 at 17:53 #48550

    Hello
    I am running squeezebox server and squeezelite on a Pi 3 B+. I am connecting to a bluetooth speaker and wireless is active.
    When I set up Accesspoint bluetooth appears to stop working. The known devices disappeared and whilst they could be found I was unable to connect. The page would just sit with the spinner running. When I uninstalled the Accesspoint server, bluetooth was operational again.

    I am aware that bluetooth and wifi are shared on the Pi 3 B+ and I guess that may be part of the problem.
    Has anyone got bluetooth and Accesspoint to work on the Pi 3 B+?

    21. April 2020 at 17:08 #48577

    Hi David,

    Accesspoint and Bluetooth shouldn’t be mutually exclusive. Of course, the two can interfere with each other regarding connection stability, but both should work at the same time. We will test this again and try to recreate the problem.

    22. April 2020 at 0:00 #48581

    Hello Mario

    Yes, I have no problem with bluetooth and wifi when it is just a wireless client. The problem occurs when it is set up as an access point.

    22. April 2020 at 13:25 #48585

    Hi David,

    What kind of power supply are you using? If the power supply is strong enough, both services may run together stably. However, due to the overlapping connections and the resulting high CPU load, the two may not fit well together in general. For the best possible quality, please consider using one service at a time.

    22. April 2020 at 23:10 #48596

    Hello Mario

    I have been using a 2A power supply. When I checked power consumption it was typically showing about 0.5A. I can test it with higher power charger if you think that will help.
    Does it use a lot more power when used as an access point as opposed to a normal wireless client?

    24. April 2020 at 14:41 #48605

    Hi David,

    Yes, the power consumption with the Accesspoint should be higher than with a WiFi connection. If you have a 2.5A power supply, you could use it to test again. It is best to also remove all other connected devices from the Pi so that they do not consume any electricity. I will also test it myself and see if it works.

    24. April 2020 at 16:05 #48606

    Hello Mario

    After the testing with Accesspoint, I received a 2.8″ display as used in your kits. When I tried the Accesspoint again it did start up along with Bluetooth and the display. When I tried to run in the standalone mode (Standalong ticked in accesspont settings and not connected to LAN) everything appeared to start. However, I was unable to connect the server and the player.

    I received the message „We couldn’t connect to <name>. Make sure your computer is turned on and connected to your local network…“

    I had ticked the box „Activate to automatically start Accesspoint Mode during boot up, if no WiFi or LAN connection is available“

    I received the information „Device is started in Automatic Accesspoint Mode…“ although it was not always consistent. Sometimes the information was not received.

    All the elements were running: Squeezelite, Squeezebox Server and Bluetooth (connected to speaker)

    Is there some point that I am missing?

    Thanks for your help.

    25. April 2020 at 13:20 #48616

    Hello Mario

    As an update.
    If I connect to the LAN then I am able to play music from a separate client connected over the accesspoint wifi, e.g. squeezebox server or Squeezer. However, jivelite on the pi is unable to connect.

    Even though I can connect to M2P over the LAN, it still treats the connection as if it is over the accesspoint wifi and I cannot restart jivelite that way.

    28. April 2020 at 14:26 #48635

    Hi David,

    Unfortunately, I am not sure whether I understood your request correctly. You have a Pi that is set up as an access point and connected to the Internet via LAN. The same Pi is also running a Squeezebox Server and Squeezelite and is controllable via Jivelite on a Touchscreen. While it is possible for you to connect another player to the Squeezebox Server via the access point and play music, it is not possible to select the player in Jivelite and play music via an output of the Pi (so to speak „locally“). Is that correct?
    For better support please tell me what you want to do with your setup and what you need the access point for.

    28. April 2020 at 14:51 #48639

    For some reason my last response is not showing so I have pasted again below.

    Hello Mario

    I am running Squeezebox Server, Squeezelite and Jivelite on a single Pi with a Touchscreen. The music is on a usb attached SSD. It runs ok on the LAN and with wifi. I want to have the option to use it in entirely standalone mode with Accesspoint. Accesspoint is all set up and is not interfering with Bluetooth since I added the display and Jivelite.
    When I start up without the LAN connected then I cannot access the music library from Jivelite.
    I get the message „We couldn’t connect to <name>. Make sure your computer is turned on and connected to your local network…“
    If I connect with the ethernet cable attached then I can access the library.
    I have selected the various options for using Acesspoint in standalone mode, i.e.:

    • Accesspoint Mode on missing network connection – ticked
    • Edit basic accesspoint settings – Standalone ticked

    I do get the message that „Device is started in Automatic Accesspoint Mode.“
    I note that I get the message 3 times in the Audioplayer tab.

    29. April 2020 at 16:27 #48662

    Hi David,

    Thanks for the detailed description. Jivelite actually seems to be having problems with the access point. Getting to the bottom of this problem is going to be very time consuming and the problem may also be unsolvable. Please enter „-s *IP address of your Squeezebox server*“ in the command line options of Squeezelite so that you can at least play your music via the Squeezebox Server web interface in access point mode. This way, the player should be accessible from the server.

    29. April 2020 at 19:27 #48667

    Hello Mario

    OK – If I understand you correctly your suggestion just enables me to use a client on my phone to control Squeezelite and server. It means that the display on the pi will not show what is playing.
    It is unfortunate that you are not convinced that the Jivelite problem could be fixed. I certainly wanted to use the pi in the way I described.

    Would it work if the Squeezebox server was on a separate pi?
    pi 1 would have Squeezebox server and accesspoint in standalone mode.
    pi 2 would have Squeezelite, Jivelite, Display, Bluetooth and Wifi

    30. April 2020 at 17:08 #48673

    Hi David,

    I asked our chief developer if there was anything he could do about it and he said that the problem should be rather difficult to solve. Why exactly do you need access point mode and can’t you use it with an internet connection? I tested the whole thing with two Pis as you described it and it worked so far. However, I recommend that you to use an internet connection if possible, because this is much more stable and reliable.

    30. April 2020 at 18:18 #48674

    Hello Mario

    Thanks for the update. This particular server is intended to be used in a vehicle. The only internet connection will be via a mifi and I would rather not have to switch that on just to get the player to work.

    There have been some further developments.
    I have been testing with a wifi dongle. I had some problems when streaming from a server over the inbuilt wifi and I thought I would try an old dongle that I had. As part of the reconfiguration, I found that resetting Jivelite helped when the server/player could not be found.
    I thought I would try reactivating Accesspoint to see if there was any improvement with the dongle. I had to do a reset of Jivelite again and the entire configuration started working.
    I cannot be sure if it is the dongle or the reset that makes the difference (or both).
    I have noticed that what is being reported in the m2p web pages is slightly strange. The health checker is showing Internet connected but it definitely isn’t.

    It does raise the question as to what is causing the problem. Certainly part of the problem is Jivelite but does having a separate dongle help. Is the problem as difficult as you think? I would need to do more testing to check. I will probably examine further when I get a replacement dongle as it is 5 years old.

    I will run the pi in this mode for a few days to see how stable it is.

    1. Mai 2020 at 14:47 #48680

    Hello Mario

    As an update.
    The new configuration has been running well so far. I have started and stopped play many times and also rebooted and restarted the pi on several occasions. It has booted into a usable configuration each time. Bluetooth did stop for no clear reason today and I had to reboot. Is there an easy way to just restart Bluetooth?
    There do appear to be a few problems associated with the inbuilt wifi/bluetooth chip. I will be testing an Edimax wifi/bluetooth dongle that I only planned to use for wifi. Do you think it would be worth using the bluetooth on the dongle as well? How do I force the system to use the dongle rather than the default chip? I used the Rasberry pi setting plugin to force the inbuilt wifi to wlan1.

    7. Mai 2020 at 13:23 #48728

    Hi David,

    sorry for the late reply. A Bluetooth dongle could certainly provide a better connection. Bluetooth dongles should be recognized automatically. With a Pi 3 that already contains a Bluetooth chip, it may be necessary to deactivate it in order to get the dongle to work. That should be possible in the Raspberry settings.

    7. Mai 2020 at 23:56 #48737

    Hello Mario

    I thought you had forgotten about me!
    The configuration has been very stable and was running for 3 days without reboot. I connected and disconnected many times without any issues.
    I found that the Edimax dongle that I had would require some work with the drivers so I will not follow that route at the moment. I will try the 7811 and see how that works. The current dongle has an antenna attached and I would like it to be a bit neater. I don’t need a big range.
    What bluetooth dongle is recommended? I couldn’t find suggestions. CSR-based dongles seem to be quite popular but they all seem to be oem and there seems to be an element of luck as to how well they work.
    You didn’t mention if there was an easy way to restart just Bluetooth. I see that there has been a discussion about what seems to be exactly the problem I have experienced https://github.com/raspberrypi/linux/issues/2832. The solutions seem to be based on a script to toggle the Wifi pins (given the pi build that I have). Is that the only option?

    9. Mai 2020 at 17:21 #48742

    Hello Mario

    I tried the Edimax 7811Un but it is causing problems. It works correctly when connecting to a WiFi network. However, when I try to connect to it in Accesspoint mode the pi just freezes. I cannot access it in any way. If I already have a fixed network connection then that link is also lost. The jivelite screen locks up completely.
    When I attempt to connect from my laptop I get the message that it is unable to connect to the network (max2play). Is there something I should be doing to get this particular dongle to work. I tried both default and nl80211 drivers.
    Are there any logs that could help. Clearly it needs to be something that is saved because all access is lost and I have to power off.

    12. Mai 2020 at 15:00 #48760

    Hi David,

    There is a Bluetooth adapter in our shop that is suitable for use with the Pi. We will see if we can add a Bluetooth restart function to our beta image. I’ll pass that on to our chief developer.

    So far, unfortunately, I cannot give you a solution to the WifI dongle in access point mode. I will finally be back in the office tomorrow and from then on I will be there at least once a week. I will then have the opportunity to test a few cases from the forum and will hopefully be able to recreate and test your setup too.

    12. Mai 2020 at 23:11 #48775

    Hello Mario

    Thanks – I hadn’t seen the adapter in the shop but I have now.

    I can confirm that the bluetooth restart as defined in the thread that I linked to does work for my version/revision of the pi (Raspberry Pi 3 Model B Plus Rev 1.3).

    
    sudo killall hciattach
    sleep 2
    /opt/vc/bin/vcmailbox 0x38041 8 8 129 0
    sleep 1
    /opt/vc/bin/vcmailbox 0x38041 8 8 129 1
    sleep 4
    sudo btuart
    

    Other methods for resetting did not work. It was necessary to insert sleep periods for all the commands to have time to complete.
    The failures appear like this in dmesg
    Bluetooth: hci0: hardware error 0x00
    Bluetooth: hci0: command 0x1003 tx timeout
    Bluetooth: hci0: command 0x1001 tx timeout

    I thought that one of the recommended wifi dongles would work but your comments cause me some concern. I have found another small adapter with the same Ralink chipset as the one that works so that might be an option. I seem to be building a collection of useless adapters!

    • This reply was modified 4 months, 1 week ago by  davidp.
    14. Mai 2020 at 16:28 #48781

    Hello Mario

    I can report that the new wifi adapter with the Ralink 5370 chipset worked straight away with Accesspoint in standalone mode.
    I just wanted to mention that the -B option for bluetooth is a great addition and makes operation with a speaker much smoother.

    I will continue to monitor bluetooth failures and decide whether it is necessary to install a separate dongle.

    15. Mai 2020 at 14:20 #48790

    Hi David,

    I am happy to hear that your system is working now. Thank you for your support!

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.

Register here