[SOLVED] Access point settings lost after reboot

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Access point settings lost after reboot

Tagged: 

This topic contains 8 replies, has 4 voices, and was last updated by  wwlippi premium 1 year, 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 28. Oktober 2019 at 22:27 #47444

    Hi,

    I tried several times to change the SSID and the password of max2play access point on a Raspberry Pi 3.
    When I save the settings I get the message
    „Konfiguration aktualisiert – existierender Eintrag wurde geändert
    Reloading advanced IEEE 802.11 management: hostapdNo /usr/sbin/hostapd found running; none killed.
    failed!“
    Not sure if settings are saved or if saving fails.

    After rebooting the Pi the new settings are shown, but when I shutdown the Pi and disconnect the the LAN cable I can’t connect to the WIFI access point with my new password. But with the old (default) password connecting is still possible.

    20. November 2019 at 14:49 #47565

    Hi steffen,

    Sorry about the late reply.

    Can you post the debug info from your access point setup?

    23. November 2019 at 21:47 #47589

    thank you for your reply.

    I get the following debug info on page „Einstellungen/reboot“

    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 30511408 2744892 26498272 10% /
    devtmpfs 443608 0 443608 0% /dev
    tmpfs 448216 0 448216 0% /dev/shm
    tmpfs 448216 13740 434476 4% /run
    tmpfs 5120 4 5116 1% /run/lock
    tmpfs 448216 0 448216 0% /sys/fs/cgroup
    /dev/mmcblk0p1 42136 22498 19638 54% /boot
    tmpfs 89640 8 89632 1% /run/user/1000

    #### LOAD AVERAGE ####
    0.22 0.13 0.05 1/234 2587

    #### KERNEL ####
    Linux max2play 4.19.30-v7+ #1209 SMP Tue Mar 26 13:14:20 GMT 2019 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 9.8 (stretch)
    Release: 9.8
    Codename: stretch

    Hope it helps.

    Steffen

    23. November 2019 at 21:49 #47590

    … and this is the debug info on page „Accesspoint Einrichtung“

    #### DNSMASQ Installed ####
    Status: install ok installed

    #### HOSTAPD Installed ####
    Status: install ok installed

    #### WiFi Interface Installed ####
    1

    #### DNSMASQ Running ####

    #### HOSTAPD Running ####

    25. November 2019 at 21:54 #47598

    Hi Heiner,

    i have exact the same issue.

    Reloading advanced IEEE 802.11 management: hostapdNo /usr/sbin/hostapd found running; none killed.
    failed!

    Hardware: Raspberry Pi 3 Model A Plus Rev 1.0

    Here are my logs:

    ############################################
    #### FILESYSTEM ####
    Filesystem 1K-blocks Used Available Use% Mounted on
    /dev/root 30419692 2904324 26250872 10% /
    devtmpfs 215984 0 215984 0% /dev
    tmpfs 220592 0 220592 0% /dev/shm
    tmpfs 220592 7988 212604 4% /run
    tmpfs 5120 4 5116 1% /run/lock
    tmpfs 220592 0 220592 0% /sys/fs/cgroup
    /dev/mmcblk0p1 42136 22857 19280 55% /boot
    tmpfs 44116 8 44108 1% /run/user/1000

    #### LOAD AVERAGE ####
    0.05 0.07 0.07 1/217 2548

    #### KERNEL ####
    Linux Grundig1042w 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux

    #### LINUX-VERSION ####
    Distributor ID: Raspbian
    Description: Raspbian GNU/Linux 9.11 (stretch)
    Release: 9.11
    Codename: stretch

    ######################################################

    Acesspoint Logs:
    #### DNSMASQ Installed ####
    Status: install ok installed

    #### HOSTAPD Installed ####
    Status: install ok installed

    #### WiFi Interface Installed ####
    8

    #### DNSMASQ Running ####

    #### HOSTAPD Running ####

    Thanks for Reply!

    Regards Björn

    28. November 2019 at 13:17 #47625

    Hi guys,

    @steffen: do you have a Model A Pi3, too? The debug from the AP plugin says that at least the facilities for it are running fine.

    @wwlippi: thanks for posting.

    You can try burning a fresh image with our new buster release to see if the problem reoccurs. However, make sure to create a backup of your current install first.

    We will try to recreate the error here.

    28. November 2019 at 15:03 #47630

    Hi guys,

    We just tested changing SSID and password of the access point for different setups but couldn’t recreate the issues you described.

    Do your passwords contain any umlauts or special characters? The system might have problems with those.

    28. November 2019 at 17:26 #47631

    Hi,

    my Password contains special character like @ and !
    I test it now with a „standard“ Password.

    Regards

    28. November 2019 at 19:06 #47640

    Hi all,

    i have now successfully tested the following:

    No change on SSID: Grundig 1042w

    Passphrase:
    change from
    Upper an lower Alphanumeric an special characters
    to
    Numeric

    A bing great Thanks for your support 🙂

    With the special characters in the passphrase the Accesspint Mode fall back to deault AP settings.

    Regards Björn

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here