Access Point Plugin auf Raspberry PI 3B+ mit PoE Hat …

Max2Play Home 2016 (en) Forums Max2Play Add-ons Access Point Plugin auf Raspberry PI 3B+ mit PoE Hat …

This topic contains 1 reply, has 2 voices, and was last updated by  MarioM Moderator 5 months, 2 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • 3. Juni 2020 at 11:46 #48939

    Hallo Max2Play Gemeinde,

    ich möchte mit einem Raspberry Pi 3B+ mit PoE HAT und einem Raspberry PI Zero W + Hifiberry Zero folgende Konfiguration erreichen:
    Der PI 3B+ ist ein LMS (Squeezebox Server), hängt sowieso bedingt durch PoE am LAN und macht einen Access Point auf,
    an welchem sich dann der PI Zero über WLAN anmelden kann.
    Der PI Zero ist ein reiner Player für den Squeezebox Server und es wäre natürlich schön, wenn der PI Zero über den Access Point vom PI 3B+
    auch noch ins Internet könnte, ist aber kein Muss.
    Es gibt leider da kein WLAN, wo der PI 3B+ verbaut ist, deshalb soll er praktisch den PI Zero ins Intranet bringen.
    Ist dies generell so realisierbar?
    Ich habe beide Geräte soweit schon konfiguriert wie nötig, nur leider startet der Access Point (Plugin) am PI 3B+ einfach nicht. ;o(
    Egal was ich probiere, Neustart, Deinstallation, er läuft einfach nicht …
    Allerdings konnte ich über das Terminal den Access Point von Hand starten: „sudo hostapd -dd /etc/hostapd/hostapd.conf“
    Dann sehe ich den Access Point endlich und konnte den PI Zero dort auch anmelden.
    Allerdings taucht aber dann wiederum der PI Zero nicht als Player im Squeezebox Server auf, also stimmt da auch wieder etwas nicht.

    Kurzum, was sind denn die exakten Bedingungen für den Betrieb eines vollwertigen Access Points als Plugin auf einem PI 3B+ mit PoE Hat?
    Was muss alles deaktiviert werden beim WLAN, was ist mit dem Autostart Access Point, an oder aus lassen?
    Kann der Standalone Modus auch bei genutzter LAN Anbindung verwendet werden?
    Was ist wenn der Access Point nicht startet/zu sehen ist, was sollte da noch gecheckt werden?

    Bin über jeden Hinweis dankbar!

    Beste Grüße aus Sachsen
    Peter Rothe

    9. Juni 2020 at 14:59 #48968

    Hallo Peter,

    An sich sollte dein Projekt so umsetzbar sein, wie du dir es vorstellst. Mit der Standard Konfiguration von Max2Play, sollte der Access Point auch ohne Probleme installierbar sein (habe es eben zur Sicherheit nochmal getestet). Bitte führe noch einmal ein Update von Max2Play durch. Wenn du den AP nach dem letzten Update installiert hast, kann es sein, dass gewisse Fixes fehlen. Ansonsten kann ich dir nur empfehlen, ein neues Image auf die SD-Karte zu brennen, das AP Plugin hinzuzufügen, dann Max2Play zu updaten und danach den AP über da Plugin zu installieren. Mit dieser Konfiguration sollte der AP auf jeden Fall funktionieren. Ansonsten startet der AP auch ein paar Minuten nach dem Booten des Pi automatisch, wenn sonst keine Internetverbindung besteht.
    Den Standalone Modus solltest du nur aktivieren, wenn dein AP selbst nicht per LAN mit dem Internet verbunden ist.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

Register here