Accespoint keine IP-Adressenzuweisung

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Accespoint keine IP-Adressenzuweisung

This topic contains 9 replies, has 2 voices, and was last updated by  Heiner Moderator 2 years, 7 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 30. April 2018 at 17:27 #35392

    Hallo,
    ich probiere seit Tagen, einen Pi mit max2play als Accespoint zu betreiben. Die SSID ist zu sehen. Dann am Handy das Passwort (ist auch richtig, ansonsten wird falsches Passwort angezeigt)eingeben und das Handy versucht ewig lange, eine IP-Adresse zu erhalten. Dann ist Abbruch.

    Wo könnte mein Fehler liegen?

    hilft eventuell dieses?
    systemctl status dhcpcd

    [email protected]:~# systemctl status dhcpcd
    ● dhcpcd.service – dhcpcd on all interfaces
    Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: enabled)
    Drop-In: /etc/systemd/system/dhcpcd.service.d
    └─wait.conf
    Active: failed (Result: exit-code) since Mon 2018-04-30 16:17:03 CEST; 1h 8min ago
    Process: 362 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -w (code=exited, status=6)

    Apr 30 16:17:03 max2play systemd[1]: Starting dhcpcd on all interfaces…
    Apr 30 16:17:03 max2play dhcpcd[362]: Not running dhcpcd because /etc/network/interfaces
    Apr 30 16:17:03 max2play dhcpcd[362]: defines some interfaces that will use a
    Apr 30 16:17:03 max2play dhcpcd[362]: DHCP client or static address
    Apr 30 16:17:03 max2play systemd[1]: dhcpcd.service: Control process exited, code=exited status=6
    Apr 30 16:17:03 max2play systemd[1]: Failed to start dhcpcd on all interfaces.
    Apr 30 16:17:03 max2play systemd[1]: dhcpcd.service: Unit entered failed state.
    Apr 30 16:17:03 max2play systemd[1]: dhcpcd.service: Failed with result ‚exit-code‘.
    Warning: dhcpcd.service changed on disk. Run ’systemctl daemon-reload‘ to reload units.
    [email protected]:~#

    Mein System:
    PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)“
    NAME=“Raspbian GNU/Linux“
    VERSION_ID=“9″
    VERSION=“9 (stretch)“

    Danke für Eure Mühe

    3. Mai 2018 at 9:40 #35502

    Hallo Hugo,

    Bitte nenn uns noch deinen Pi und ggf. andere Geräte die du angeschlossen hast, sowie die Schritte zur Einrichtung des Access Points. Wir werden versuchen, das Problem zu reproduzieren.

    Hast du schon versucht, den AP als Standalone zu betreiben?

    4. Mai 2018 at 11:13 #35518

    Hallo,
    danke für die Rückmeldung.
    Also der AP im ISO (Name max2play, Passwort mypasscode) funzt. Aber da kann man ja die SSID und das Passwort nicht so einfach ändern. Wozu ist dann die Erweiterung in derPlugin-Konfiguration noch zusätzlich? Dort kann man SSID und Passwort einstellen, aber es geht nicht, siehe oben.

    Ich habe einen Pi3+ mit Stretch und HIFIBERRY+ und sonst nichts. Ich möchte ihn (zu Himmelfahrt… 😉 ) als Standaloneplayer mit MPD an Aktivboxen nutzen. Daher meine anderen Fragen hier im Forum.

    Dankeschön

    7. Mai 2018 at 16:10 #35559

    Hallo Hugo,

    Danke für die detailierte Antwort. Ich konnte den Fehler reproduzieren und werde ihn zu den bekannten Bugs hinzufügen. Wir werden umgehend nach einer Lösung suchen und dich natürlich informieren sobald diese erhältlich ist.

    7. Mai 2018 at 16:36 #35560

    Und schon die Rückmeldung.

    Es scheint sich um eine Dependenz mit dem automatischen Access Point zu handeln. Wir haben diesen behoben in der aktuellen Beta.

    Um das auch bei dir zu haben, mach einmal folgendes: Installiere die aktuelle Beta von Max2Play in Settings/Reboot -> „uninstall“ den Access Point in Access Point Setup -> installier den Access Point dort neu.

    Danach sollte es klappen 🙂

    8. Mai 2018 at 8:33 #35570

    Moin,
    Dankeschön. Ich probiere es aber erst nach Himmelfahrt aus, da ja der Behelfs-AP erstmal läuft.

    Dennoch Dankeschön

    30. Juni 2018 at 10:51 #36418

    Moin,
    ich mal wieder.
    Also ich habe einen Raspi-Zero komplett neu aufgesetzt. Funktioniert solange, bis ich den Accesspoint installiere. Ab dann habe ich keinen Zugriff mehr. Im Netz ist er nicht, und ein AP ist auch von ihm nicht zu finden.
    Ich verstehe nicht, warum soll man den AP installieren, wenn doch schon einer bei der Installation dabei ist? Und warum kann man diesen nicht konfigurieren?

    Beim Zero habe ich das Problem, wenn das WLAN weg ist, komme ich nicht mehr auf die Kiste. Beim Raspi hat man wenigstens noch das LAN-Kabel.

    Oder mache ich was Grundsätzliches falsch? Hat jemand den Zero mit HIFI-Berry in Betrieb?

    Liebe Grüße

    9. Juli 2018 at 14:16 #36495

    Hallo Hugo,

    Der automatische ist nur zur Einrichtung des Heimnetzes, falls kein WPS vorhanden oder erwünscht ist. Als echter Access Point ist er nicht empfohlen.

    Gehe bitte sicher, dass eben dieser auch deaktiviert wird, nach der Einrichtung im Heimnetz, um einen eigenen Access Point im Nachhinein einzurichten.

    9. Juli 2018 at 16:46 #36500

    Hallo Heiner,
    und wie soll ich den echten AP einrichten, wenn der andere deaktiviert ist? Wie komme ich dann auf meinen Raspi-Zero? Schon wenn ich ihn nur installiert habe, gibts keine Verbindung zum Netz. Da kann ich nichts einrichten.
    Irgendwie besst sich die Katze in den Schwanz.

    11. Juli 2018 at 16:03 #36539

    Mit Verbindung mit Ihrem WLAN-Netz. Sie nutzen den automatischen AP NUR zur Verbindung mit einem bestehenden WLAN-Netz. Danach können Sie über jedes Gerät in Ihrem lokalen WLAN alles andere, wie auch den richtigen Access Point einrichten.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here