2,8" Watterott Touch Display with a Hifiberry DAC+ (B+) cannot activate both

Max2Play Home 2016 (en) Forums SD-Card Imaging and getting started 2,8" Watterott Touch Display with a Hifiberry DAC+ (B+) cannot activate both

This topic contains 8 replies, has 2 voices, and was last updated by  Heiner Moderator 6 days, 20 hours ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • 2. September 2018 at 19:00 #37617

    Hello,

    My Setup:
    ————————————-
    Hardware:
    * Raspberry Pi 1 B+
    * Watterott 2,8″ Touch Display
    * Hifiberry DAC+

    Software:
    *Max2Play Version 2.46
    ————————————-

    My problem is, I want to use the Hifiberry and the Watterott Touch-Display at the same time. When I activate in Max2Play in the navigation bar the Touch-Display the Hifiberry isn’t working anymore. (Touch Display is now working)
    When I activate the Hifiberry in the navigation bar the Touch Display stays black. In the navigation bar the Display seems to be deactivated again.
    I know there is a GPIO-pin (GPIO 18) that is used from both devices.
    I changed the signal from GPIO 18 to GPIO 12 from the Display. (That is done by closing the Jumper on the back of the Watterott Dispaly and by changing the DeviceTreeOverlay „rpi-display.dtbo)

    Each device is working fine stand alone. But I can not get both of them together.
    I hope someone can help me out here.

    Thank you very much

    Best wishes
    Manuel

    3. September 2018 at 13:53 #37627

    Hi Manu,

    Generally, we recommend using only one of the two HAT solutions with each Pi.

    You could try a stronger PSU (2.5A recommended).

    3. September 2018 at 19:17 #37629

    Hello Heiner,

    thank you for your Answer.

    I don’t think it is the PSU,
    because I already installed sucessfully both HATs on a Raspian Image. Same components …
    (btw, I am using 2.1A Power Adapter)

    The thing in Max2Play is, it seems to me when the DeviceTreeOverlay of the Hifiberry is activated, then the DeviceTreeOverlay of the Display will be deactivated.
    Is that possible ?

    4. September 2018 at 16:17 #37632

    Did you already install both HATs simultaneously running on one Pi or individually?

    5. September 2018 at 17:19 #37660

    Yes both HATs simultaneously on one Raspberry Pi
    Image both HATs working with Raspian Image
    https://ibb.co/g6Eh0K

    • This reply was modified 2 weeks, 5 days ago by  Manu.
    • This reply was modified 2 weeks, 5 days ago by  Manu.
    6. September 2018 at 22:25 #37712

    My Problem in pictures. I hope it helps to understand it better …

    https://ibb.co/fAkJQK
    https://ibb.co/dDEZze
    https://ibb.co/bK3isz
    https://ibb.co/bLp1ee

    10. September 2018 at 11:18 #37734

    Hi Manu,

    Thank you for the detailed documentation.

    I would assume that the issue is somehow connected to the change in GPIO mapping.

    When you mentioned you had both running simultaneously, did that mean that you could both control the touchscreen and run music through the DAC? Please test this with the normal Raspbian to make sure it is not a hardware issue.

    15. September 2018 at 13:25 #37850
    18. September 2018 at 11:31 #37887

    Hi Manu,

    Unfortunately, we do not have experience with this setup and cannot offer any tips or help.

    However, the HiFiBerry support forums are probably your best bet for good feedback on how to get this work.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

Register here