Reply To: Airtunes Drops in and out

Max2Play Home Forums Max2Play on Raspberry PI Airtunes Drops in and out Reply To: Airtunes Drops in and out

19. November 2021 at 15:49 #51803

Hi MarioM,

Thanks much for responding!

First, yes, Squeezelite is not required to stream Airplay via Shareport. However, everything else I use this system for requires Shareport. I can’t stream radio, play local media, etc., without Squeezelite. So, yes, the issue appears to be an incompatibility between Squeezelite and Shareport, but stopping Squeezelite every time I want to use Airplay is just not a good solution.

I’ve gone through the link you sent pretty carefully, and I’ve had to insert the IP address of the Squeezelite server into Shairport to even get this far.

I’ve tried using the Shairtunes 2 (fork) as well. I’m using the Shareport_Helper-armv6f as the helper binary since (as I understand it) the Broadcom BCM2837 processor in my RPi3b is an Arm processor derivative.

In any case, with Shareport stopped, the Shairtunes 2 (fork) plugin installed, and Airplay running, I get the same issue; Airplay breaks up. Playing a song… is impossible… listening to a podcast via Airtunes is … irritating, because of the audio gaps.

I have had some good discussion with Phillipe G. on this. He’s been exceptionally responsive and very helpful on trying to help me. His recommendation was that Shairtunes should not be required; Shairport should work.

I’ve also tried using Airplay Bridge. However, after installation of the plugin, attempting to get to the Settings tab … Airplay Bridge never responds.

So I remain stuck. I much appreciate any input you can provide.

Thanks again!