Reply To: Probleme mit dem mounten vom Mediaordner

16. Juli 2021 at 19:03 #51475

Ja, das sehe ich auch so, dass es da noch ein Problem gibt 😉 Hatte heute übrigens auch den Medienordner wieder nicht zur Verfügung und habe wirklich keine Änderung vorgenommen.

Kurzes Protokoll, was ich heute also alles gemacht habe:
1. kompletter Neuscan der Datenbank
2. nochmals versucht eine Playlist anzulegen – mit bekanntem Fehler nicht funktioniert
3. Verzeichnis direkt auf dem Pi ausgewählt /usr – mit bekanntem Fehler nicht funktioniert
4. ein Verzeichnis lokal auf dem Pi für Playlists ausgewählt (/usr) – mit bekanntem Fehler nicht funktioniert (per ssh überprüft, es war auch keine Datei zu finden)
5. per ssh als Nutzer pi angemeldet und versucht einen neuen Ordner anzulegen – Fehlermeldung „keine Berechtigung“
6. das Gleiche mit sudo mkdir funktionierte dann
7. Playlist im neu angelegten Verzeichnis versucht anzulegen – wieder der bekannte Fehler:
[21-07-16 18:35:59.3877] Slim::Formats::Playlists::Base::_filehandleFromNameOrString (86) Error: Could’t open /playlists/Testliste 3.m3u for writing.

8. Neuen User in der Synology angelegt. Hat nur Leserechte für die Medienbibliothek und Lese- und Schreibrechte für den neu erstellten Ordner Playlist.
9. Mit diesem Nutzer gemountet, Bibliothek neu durchsucht, Playlist erstellt – wieder der bekannte Fehler

Wenn ich nach neuen und veränderten Mediendateien suche, dann sind die Playlists immer noch in der Datenbank zu finden und auch so abzuspielen. Müssten die nicht auch gelöscht werden, wenn die doch gar nicht abgespeichert werden?
Einen ähnlichen Effekt hatte ich, als der Mountpoint nicht richtig geladen wurde und ich versucht habe 2 songs aus einem Album abzuspielen. Die wurden nicht gefunden und aus der Datenbank gelöscht. Nachdem die Medienbibliothek auf der Synology wieder richtig geladen wurde, hat auch ein Scan nach neuen und veränderten Mediendateien mir diese 2 Songs im Mediaserver nicht wieder gebracht. Abspielen konnte man sie ohne Probleme, wenn ich über die Musikordner gegangen bin, aber im Album wurden sie nicht angezeigt.
Datenbank löschen und alles neu durchsuchen hat mir diese 2 songs wiedergebracht und die Playlists sind danach verschwunden.

Ich würde ja alles neu aufsetzen, wenn ich das nicht schon 2x gemacht hätte…

Viele Grüße
Uwe