Reply To: Auxiliary output randomly stops working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Auxiliary output randomly stops working Reply To: Auxiliary output randomly stops working

19. Februar 2019 at 16:49 #44528

Hi Peter,
1. On the ‚Mainroom‘ Raspberry Pi 3+ you have Squeezelite, Bluetooth and Multi-squeeze running. You are streaming sound from your USB soundcard and a device connected to the 3.5mm audio jack.You own a 3a 5v power supply wich you are using with your ‚Mainroom‘ Raspberry Pi+
I have one Raspberry Pi 3+ running Max2Play with Squeezebox Server, Multi-Squeeze and Bluetooth. I also recently installed an OpenHAB server on it as well, but that is a completely separate process. The Pi is now called „Smartroom“ and is powered through a proper 5V 2.5A/3A power supply. It is connected to one amplifier through the 3.5mm audio jack, and is also connected to another amplifier through a USB soundcard.

Your ‚Mainroom‘ Pi 3+, was working fine until suddenly the audio jack stoped working.It started working again After a software reinstall. The audio jack worked for aprox. 5 days before it stoped working again.
Yes, and I needed to completely format and reflash the SD card. I really don’t want to do this again if possible.

At the end of January the audio jack still doesn’t work, and you have almost given up on bluetooth to work also. However you do not uninstall the plugin.
Yes, the audio jack doesn’t work. Bluetooth doesn’t work when going through Squeezebox, so I uninstalled it for a while but the audio jack didn’t start working again. I later reinstalled it.

2. February: Your installation has changed you are no longer streaming/playing from one Raspberry pi 3+ ‚Mainroom‘ with a USB card and a 3,5mm audio device. The second device is called ‚desk‘ player. The second player also have a defect audio jack. You tried with the same SD card and sound cards with the same result and therefore think that the problem is the software.
No, I am still using the single Raspberry Pi with multisqueeze (which allows multiple players). I have tried using a different Pi, power supplies and soundcards however these have the same result, so yes, I do think that the problem is the software.

3. On the 18th you send me your Pi’s boot report (Demsg) from a Raspberry Pi called ‚Soundsystem‘ properly with new installed software and clearly not the same as the Pi called ‚Mainroom‘. Maybe a third PI??.
The single Pi called „SoundSystem“ is the same Pi I used all along. „Mainroom“ and „Desk“ are just names of the Multisqueeze players.

A finally one of the first thing I asked you to do was telling me the status of the settings of Squeezelite and Shairport in the Audioplayer tab. On the 15th. you told me that the status was: Active: inactive (dead). also not running.

On the 18th you wrote: I disabled the autostart of Squeezelite and Shairport in the AudioPlayer tab, however they still seem to start and run and the 19th you wrote: I cannot stop squeezelite and shairport (Trying to stop … could NOT stop process – try kill instead) and sometimes kill does not work. When I do manage to kill the processes, once I reload the page they have started again. The checkboxes are unticked.
Yes, that is correct. I still don’t really understand what the statuses meant when I sent them to you.

I now know that there are only one person who can solve the mystery of the sudden death of the auxiliary output!!!

And that person needs to find out who, how and what in the chase of the unstoppable process!! first.
I don’t really know what you mean

Until then I wish you a happy reinstalling!!
If possible, I really don’t want to reinstall everything as it will take me a long time to get everything reconfigured. I can reinstall individual software but ideally I don’t want to get a new image.

Thanks