Reply To: [UPDATE BUG FIX] Bluetooth Addon BETA

Max2Play Home 2016 (en) Forums Max2Play Add-ons [UPDATE BUG FIX] Bluetooth Addon BETA Reply To: [UPDATE BUG FIX] Bluetooth Addon BETA

16. Januar 2019 at 21:22 #43762

Hallo Zusammen,

auch ich bekomme mein BT-Streaming vom Handy auf den Pu und dann auf den Sequeezebox Server nicht zufriedenstellend hin.

Meine Konfiguration:
What Raspberry Pi do you use and what Max2Play SD-Card-Image did you install?
–> Raspi 3B+ mit Raspberry Pi Shield – HiFiBerry DAC+ RCA
–> Dieses Raspi ist auch mein Squeezebox Server und LSM läuft logischerweise darauf. Momentan habe ich noch ein weiteren Client verbunden.
–> SD Carf image: m2p_stretch_rpi_v247.img
What Max2Play-Version do you use?
–> 2.47
Do you use a Bluetooth dongle? If yes, which one?
–> No, internal Raspi BT module
What is the output of the „DEBUG“ window at the bottom of the bluetooth addon?
–>
#### Bluetooth Installation ####

#### Bluetooth Dongle ####
hci0: Type: Primary Bus: UART
BD Address: B8:27:EB:3E:31:9B ACL MTU: 1021:8 SCO MTU: 64:1
UP RUNNING
RX bytes:34756725 acl:62045 sco:0 events:1263 errors:0
TX bytes:37917 acl:1482 sco:0 commands:164 errors:0

#### DEVICE blacksurfer ####
[**MAC ID**]
Name: blacksurfer
Alias: blacksurfer [rw]
Address: **MAC ID**
Icon: phone
Class: 0x7a020c
Paired: 1
Trusted: 1 [rw]
Blocked: 0 [rw]
Connected: 1
UUIDs: [00000000-deca-fade-deca-deafdecacafe, ServiceDiscoveryServer, AudioSource, AVRemoteControlTarget, AdvancedAudioDistribution, AVRemoteControl, NAP, HandsfreeAudioGateway, PhoneBookAccess, 00001132-0000-1000-8000-00805f9b34fb, PnPInformation, 02030302-1d19-415f-86f2-22a2106a0a77]

#### BLUEALSA RUNNING ####
1

#### BLUETOOTH SQUEEZEBOX SERVER AUTOSTART ####
Logfile was modified.
Reading last 10 lines of /var/log/daemon.log
NEW Bluetooth state: 0 | OLD Bluetooth state: 1
Off – Stop Stream on Squeezebox Server (Restore Stream before Bluetooth)
Socket created
Sending : playlist deleteitem wavin:bluetooth
Socket created
Sending : playlist index -1
Socket created
Sending : playlist play

What exaclty is not working? Pairing, Connecting, Playing Audio, Reconnecting on Reboot,…
1. Bluetooth Plug-IN ist erfolgreich installiert und gestartet
2. Handy iPhone mit iOS12 verbindet sich erfolgreich mit dem Raspi
3. iOS zeigt die Verbindung an
4. im m2p BT Plug-In wird mir auch die Verbindung durch grüne Markierung der Handybezeichnung angezeigt
5. Ich starte „Stream zum Squeezebox Server“ im BT Menü. Die Installation des „Bluetooth Streaming zum Squeezebox Server“ ist abgeschlossen. (Bluetooth wird ebenfalls in den Favouriten des LMS angezeigt)
6. „Autostart Bluetooth-Streaming im Squeezebox Serve“ ist aktiviert.

Was ich nun mache, ist sicherstellen, dass sich mein Handy mit dem BT des Pi verbunden hat: check
Dann starte ich Musik über die iTunes App oder über amazon music oder ähnliches auf dem Handy.
Ich lasse mir via airplay im Handy zeigen, dass die Verbindung zum Pi nach wie vor steht. iPhone Symbol: Lautsprechetzeichen vor dem Bluetooth-„Runen“

In iPeng oder/und im LMS kann ich Bluetooth aus Quelle wählen. Ich bekomme jedoch keinen Sound auf die Boxen.
Als „Liedtitel“ wird ‚wavin: bluetooth – Bluetooth‘ angezeigt. Aber wie gesagt, keine Musik.

Check your Power Supply! Most problems result from unsufficient power – remove all usb-devices, drives and displays to see if this solves the problem.
–> 5V 2100 mA @ mini USB vom Raspi

Alle anderen Funktionen udn Features und Plug-Ins funktionieren problemlos. Aber die möglichkeit per BT auf den Squeszebox-Server zu streamen ist eben schon seeeeehr sehr nützlich!

Danke für die Hilfe!

Viele Grüße,

Philip