Reply To: [SOLVED] Spotify connect problems

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Spotify connect problems Reply To: [SOLVED] Spotify connect problems

14. März 2018 at 9:38 #34413

Hi Heiner,

I have updated the plugins in the webinterface „Einstellungen / Reboot“ und then the spotifyplugin reinstalled. Now I get another error, when I try to connect with SpotifyConnect:

#### Librespot Output ####
INFO:librespot: librespot cc9dba8 (2017-03-26). Built on 2017-07-17. Build ID: 8zQE3Bpb
INFO:librespot::session: Connecting to AP "gew1-accesspoint-b-zjkl.ap.spotify.com:4070"
INFO:librespot::session: Authenticated as "USERNAME" !
INFO:librespot::audio_backend::alsa: Using alsa sink
INFO:librespot::session: Country: "DE"
thread 'main' panicked at 'called <code>Result::unwrap()</code> on an <code>Err</code> value: WireError("invalid value for enum: 13")', /checkout/src/libcore/result.rs:859
note: Run with <code>RUST_BACKTRACE=1</code> for a backtrace.

#### Librespot Command Line Options ####
error: Required option 'name' missing.
Usage: /opt/spotifyconnect/librespot [options]

Options:
    -c, --cache CACHE   Path to a directory where files will be cached.
        --disable-audio-cache 
                        Disable caching of the audio data.
    -n, --name NAME     Device name
    -b, --bitrate BITRATE
                        Bitrate (96, 160 or 320). Defaults to 160
        --onstart PROGRAM
                        Run PROGRAM when playback is about to begin.
        --onstop PROGRAM
                        Run PROGRAM when playback has ended.
    -v, --verbose       Enable verbose output
    -u, --username USERNAME
                        Username to sign in with
    -p, --password PASSWORD
                        Password
        --disable-discovery 
                        Disable discovery mode
        --backend BACKEND
                        Audio backend to use. Use '?' to list options
        --device DEVICE Audio device to use. Use '?' to list options
        --mixer MIXER   Mixer to use

Then the SpotifyConnect service is stopping.

I have add the IP adress of the device in the option of the plugin.

Because of these errors I have updated my system withe the commands „apt-get update“ and „apt-get upgrade“ to the newest version of „jessie“. But without success…

  • This reply was modified 3 years, 1 month ago by  Stefan121.