Reply To: [SOLVED] Spotify Connect does not start

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Spotify Connect does not start Reply To: [SOLVED] Spotify Connect does not start

3. März 2018 at 13:23 #34192

So, I decided to give that new beta a try, Version Beta-180301 on Raspberry PI B+, and have spent some hours pulling my hair out since then.

Even with the google DNS hack in place, I have no internet on the max2play after installing this beta.
Well, that means, no DNS, because I can connect to it via webinterface and ssh without a problem, so the connection is there, but pinging a server by name from the raspberry gives an „unknown host“ error.

Did a full reinstall this morning, first trying to get it all working without installing a beta release, but all I got at first was the illegal instruction for librespot, and then, after following the instruction from arch above (https://www.max2play.com/en/forums/topic/spotify-connect-does-not-start/#post-33354), all I got when trying to start spotify connect was

hread ‚main‘ panicked at ‚called Result::unwrap() on an Err value: WireError(„invalid value for enum: 13“)

Googling for this doesn’t help me much, just a few hits on GitHub with too much tech details (even though I think of myself as tech savvy).

After the first reboot on the beta release, I get the no internet error, persistently…

So… basically, now I can start over again with installing, but then I will still not be able to use spotify connect, which for me was the whole point of using max2play…

Any hints welcome! Basically, without internet access (without a functioning DNS), this thing is useless…
If there’s any useful logging I can get, let me know.

If only I hadn’t tried out the latest beta, I would still be enjoying spotify connect. Is there a way to go back to the previous beta?

  • This reply was modified 3 years, 7 months ago by  kraker. Reason: minor addition