Reply To: [SOLVED] How to get a stable M2P installation … TL/DR

15. Februar 2018 at 2:44 #34015

Heiner – I’m very sorry to have to tell you that today I have redone my RaspberryPi installation and moved to a stock Raspbian and I’ve done the work to install LMS, SqueezeLite, and configure it for using my HiFiBerry audio hardware by hand. Thankfully I have long experience in *nix operating systems (having been an ERP app admin for half my career at my current employer) and I know my way around Google and forums. I’m listening to an audio stream now as LMS scanning my music collection.

I did want to tell what happened because it’s been 8 weeks since my last post and, again, the Max2Play system somehow, magically, was hosed over night. LMS was working last evening. I listened to a playlist as I went to bed. Today I worked from home after a dentist appointment and when I tried to use the SqueezeBoxServer web UI to create a playlist, the UI was missing elements!

So, I opened http://max2play and restarted SqueezeBoxServer. I got a „restart successful“ message, but could not connect to <host>:9000. I restarted again. No SqueezeBoxServer on port 9000. So, I rebooted the RPi. On reboot the Max2Play Admin UI said SqueezeBoxServer was not installed.

WTF?

I know you and your colleagues do excellent work–the M2P UI is really nice and it’s easy to use. But this is now the FOURTH time my SqueezeBoxServerinstall has mysteriously become hosed. I’ve done nothing to the install; it’s been working flawlessly since I reinstalled it. And this time it’s with a brand new RPi3 that I bought after our last interactions (see above). I’ve since bought a NAS so there is no issue with USB or power, etc. (which required only a mount in the M2P config and a rescan). And yet, again, SqueezeBoxServer becomes unusable and … well, I’m done.

I know ditching M2P won’t help you figure out what’s going on, but I’m not willing to wait until something could be figured out. I just want it to work and not fail when I’m not doing anything to it except listening and occasionally adding new music (and the rescan that requires). Max2Play isn’t giving me that. Wish it did.