Reply To: Install M2P-244 w/o WPS

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Install M2P-244 w/o WPS Reply To: Install M2P-244 w/o WPS

19. September 2017 at 21:27 #31407

Thanks Heiner,
I typed this just now without referring to my previous post, so I hope that the story is the same.

Sorry for the delay. A short vacation and more important projects.
To review: I installed a new router, the Netgear Nighthawk AC1900,
then quickly installed dd-WRT which does not do WPS. So the router
security is WPA2/AES.

Afterwards, all of my wifi devices automatically connected to the
new router except that 2 Squeezeboxes needed to do „Network Setup“, and the 2 max2play rpi3’s that were dead-in-the-water.

I started with the rpi that is the LMS server/squeezeplay. I downloaded the new max2play version 2.44 and installed it on the SD card. After bootup I connected a laptop to wifi „max2play“ and the „Wifi/LAN“ Tab. I checked the „Load Wifi Interface“ box, entered my SSID and password, then clicked „Save all settings“. It didn’t work, I couldn’t get it to work.

So I connected a monitor and a keyboard to the rpi, and booted to the
raspbian login prompt. After logging in I edited /etc/wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid=“myssid“
psk=“mypasskey“
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
}

It immediately connected and has been working ever since. For weeks now, and before I went on vacation.

So yesterday I found time to try to get the other max2play rpi3 working. I had tried before, but was unable. So to start fresh, I fomatted the SD card and installed the version 2.44 image. Again I tried to get Autostart to work, but could not. So I again connected a monitor and keyboard to the rpi, but this time it booted through to a „primitive“ max2play desktop GUI. I have no clue why it booted differently than the other one that booted to the raspbian
login. So I found the Xterm in the desktop, and again edited the /etc/wpa_supplicant.conf file the same way. I then checked the router at 192.168.1.1, and it showed that „max2play“ was connected at 192.168.1.8. I then did a „sudo halt“ shutdown, and took the rpi „downstairs“. After plugging in and waiting for the boot, I looked at „squeezer“ on my phone: max2play did not connect?!? Did max2play really override my wifi settings that worked, well maybe
they would have worked? Then I used a laptop to check the router connections, max2play was,of course, missing.

I then switched the laptop to the „max2play“ ssid, and connected via browser to the Wifi/LAN tab.
I entered the same info as before into the Wifi/LAN tab, and again got the same result, here are some specifics:
When I clicked the „Save all settings“ I would usually see the same rotating circle, and the screen would become translucent. After a short wait I would check the laptop’s wifi to find that it had
somehow switched from „max2play“ to my-home-network. That’s unusual!! When I switched back to „max2play“ wifi the Wifi/LAN tab then displayed failure info which I copied, see attachment. (I don’t see a way to attach my photo, so I’m sending this before it gets lost.)

I hope that I’ve been able to explain everything adequately, don’t be afraid to tell me that I didn’t follow directions.