Reply To: [SOLVED] How to get a stable M2P installation … TL/DR

4. September 2017 at 17:01 #31131

Heiner,

I thank you for your reply. I realize that Max2Play has users/customers with a broad range of experience. I am one of those with much experience — 30 years in IT, over a decade of that as an ERP system administrator using Solaris systems for a large American public university. I used Linux as my primary home OS for 20 years (first Linux install was Slackware 1.0 and I’m using as I type LinuxMint 18.1). I know my way around a computer. When dpkg installs the LMS .deb package in 5 minutes, but a web-based process doing the same is not concluded in 30 minutes, then I „grow weary“ of the process. There can be many underlying issues that seem to prevent the installation conclusion I know, but nonetheless it seems that 30 minutes is, well, not right.

I say this not to brag (there are certainly people who have greater knowledge than I do — kernel developers are astounding!) or find blame (truly–I know you and your colleagues at Max2Play do your best at a difficult task), but to show that my comments are not random or simply those of an impatient person. I really did work for five hours trying to „fix“ the M2P/Pi2/LMS systematically looking through config files to see if I could discover anything relevant.

I understand, from your perspective, that a customer who does such things poses a support nightmare — you cannot know what I’ve done and thus cannot begin to offer real help. I know that what I did presents difficulties for remote support (god knows I’ve had to deal with similar things in my own career). That is why I did not ask for such help — I asked for any approaches I can take to provide stability *after* I had re-imaged my M2P/Pi2 install.

But you do give me a hint of how apps like M2P should be considered–simply backup and when there are issues re-image the system and restore the backup (and from now on forget any thought of „fixing“ or „trouble-shooting“). Which I shall do from now on because when M2P is working well it is a very, very nice application (which I why I had no issue paying for it).

And, after all that, I’m quite happy to say that the new 2.44 image is already better than the 2.43 image. The LMS install completed in less than 10 minutes, as I’d expect. The 3-minute install loop that did not conclude, that I mentioned above, did not occur with the 2.44 M2P version. Also, though M2P/Pi2 is connecting to the same USB drive, the LMS library scan only took 2.5 hours and not 4+ hours. LMS already seems more responsive (could just be me happy to have it working again).

Thanks to the M2P developers who worked on this new M2P version!