Reply To: HD audio – 192kHz/24 not working on HifiBerry Digi+ Pro

26. Juli 2017 at 17:18 #30175

What audio output do you have selected in Audioplayer menu?

It is set to Default: (Use HDMI if plugged). My assumption, which may very well be incorrect, is that this only applies to the RPi onboard output options, hdmi vs 3mm phone jack. I also assume this should not have any impact if the digi+ is processing the output. What is the „correct“ setting?

Disabling bluetooth and Build-in audio were both tried without success. I’ll disable them again, since for all practical purposes I will probably never need either. It’s possible I tested them one at a time; perhaps the combo of them will matter.

Your pointers to the sound optimiztion links lead me to a whole new world of info on amixer/alsamixer, etc.

One of the gems out there is /var/lib/alsa/asound.state.

Here’s the config for the hifiberry… does it look reasonable. To me it looks rather uninteresting, state.IQaudIODAC has 16 controls.

state.sndrpihifiberry {
control.1 {
iface MIXER
name ‚Tx Source‘
value AIF
comment {
access ‚read write‘
type ENUMERATED
count 1
item.0 ‚S/PDIF RX‘
item.1 AIF
}
}
}

I can test using a hard connection to the lan, but I’ll need to get a 40′ patch cord. Then deal with the wife.

I guess this is how one learns…

Thanks,