Reply To: M2P 2.40 + RPi3 + Hifiberry Amp = no Wifi and WPS not working

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI M2P 2.40 + RPi3 + Hifiberry Amp = no Wifi and WPS not working Reply To: M2P 2.40 + RPi3 + Hifiberry Amp = no Wifi and WPS not working

12. März 2017 at 17:52 #27603

Kind of same problem, ‚M2P 2.40′ + RPi3 + JustBoomDac = ’no wifi‘
I have put a checkmark in ‚Load WiFi Interface‘ and pressed ’save all settings‘ which gives a wierd error message of ‚Fail OK‘.

I have tried M2P version 2.41, same problem/result..

By disabling ‚WPS‘ and press ’save‘, i’ve got a message reffering a problem with /var/run/wpa_supplicant/wlan0 wich lead me to the solution.
The path ‚/var/run/wpa_supplicant‘ is not existing, so by creating a directory ‚wpa_supplicant‘ in ‚/var/run/‘ i got wifi working..
(then i went to the web interface for wifi and redid the checkmark in ‚load Wifi interface‘ and clicked ’save all settings‘ and then the result was ‚OK‘ and wifi started to work.)

Created the directory by executing ‚mkdir /var/run/wpa_supplicant‘ in a root terminal.

-> Max2Play: Could you pls. make sure the directory exist in you next release please, thanks..

  • This reply was modified 3 years, 7 months ago by  realsurfer.