Reply To: DTS Pass through

4. February 2017 at 1:51 #26667

I’d like to resurrect this thread if I may. I recently installed Max2Play on a new Raspberry Pi 3 and have encountered this same situation where DTS isn’t working via HDMI.

The DTS material is in a FLAC container and works fine through genuine Logitech hardware, through a Wandboard Quad and via piCorePlayer using either a HiFiBerry Digi+ or HDMI.

The issue is likely that the audio Squeezeplay is sending out through HDMI has been altered in some subtle way, which “breaks” DTS and AC-3. I *think* this just works right away in piCorePlayer now, but in the past users had to make some minor modifications. I have pasted below the instructions I was given, which worked successfully. (Nothing from this point on was written by me.)

1) Login to your piCorePlayer via SSH.

2) Set the ALSA output level to exactly 0.00db and save it for future
reboots with the following commands

a) find out the simple mixer ID of your sound card

Code:
——————–
amixer scontrols
——————–

–> the output in my case is

Code:
——————–
Simple mixer control ‘PCM’,0
——————–

whereas ‘PCM’ is the important part for the next command

b) set the output level to 0.00db

Code:
——————–
amixer sset ‘PCM’ 0
——————–

c) save & backup the ALSA settings

Code:
——————–
sudo alsactl store
sudo filetool.sh -b
——————–

4) set ALSA output level to Custom in the piCorePlayer web interface
(under Tweaks –> Audio Tweaks) and save the change.