Reply To: Squeezelite not recognized as player

22. November 2016 at 16:26 #24090

Heiner,
Not sure if this is a similar problem to the one Ole has outlined above (apologies for hijacking if you think this is not the case).
I have recently rebuilt my multi-room speaker systems.
I used to play my music from a Synology NAS but was concerned about disk thrash so I built a Raspberry Pi with a big USB stick to act as repository (all solid state only read required noatime) ;-).
I then decided that I only used the Pi-NAS with the speakers so why not build the NAS in ???
I did this and it worked and used another Pi as another synchronised speaker system – ALL OK
I recently built 3 more boxes to house Pi’s, PSU’s, Amps and Speakers (and a front button to allow gracefully startup/shutdown)
I upgraded my images and used them to build the microSD cards on all the M2P Pi devices.
The server/player works as a server and player sitting on the network (player identified with ‘-s 127.0.0.1’ to speed loading of local player) and also using a WiFi dongle to create an access point for the satellites/me_(with my phone/tablet controller) to connect to if out of the house (also used in Garden or at other people’s parties). The satellites have been configured to connect to multiple WiFi networks (should be allowed under your m2p interface, but had to manually edit ‘/opt/max2play/wpa_supplicant.conf’ to allow this). – Again works okay.
I don’t like signing in as root (to the samba server to upload more music), so modified your standard fsab offerings to ‘defaults,noatime,rw,uid=0,gid=100,nofail’ so that root ‘pi’ and any other user added to the ‘users’ group can write and all remaining ‘valid’ users just read. – Again all okay.
I can use the web interface of the LMS server to control / synchronise players, so most everything works fine.
The issue I have is that I prefer to use ‘Squeezer’ as my phone / tablet interface but though it will identify the server IP address and correct port … it will not identify ANY players. It just reports ‘squeezer’ and sits there doing nothing. ;-(((
I think I used to have this issue before but it eventually found the local player after a while (which is why I use the ‘-s 127.0.0.1’ on the local player as that reduced the time). I have left these systems for most of a day and still not seen the players show up.
I have tried (as you suggest above) to rename the players but you do not specify how.
1. I have renamed them via the LMS web interface (only lasts to the next reboot and doesn’t work anyway)
2. I have renamed the Library via the LMS web interface (does not seem to affect anything and will not let you reset this to blank afterwards)
3. I have used the m2p web interface to rename the Pi’s (does not work before the reboot or after it either)
Is there anything that has changed in the m2p builds (fully updated in all cases) that would affect this ? Or have I been stupid and missed something vital ? Or should I be looking to talk to the ‘Squeezer’ developers to see what they have changed ?
Thanks
Mark

  • This reply was modified 1 week, 5 days ago by  MarkMutt. Reason: allowed for the fact that I may have done something wrong ;-(((