Reply To: No sound after a few hours

Max2Play Home 2016 (en) Forums Max2Play Add-ons No sound after a few hours Reply To: No sound after a few hours

9. November 2016 at 17:00 #23840

Hi LowTech,

dein Grundproblem im Setup mit Squeezelite scheint zu sein, dass standardmäßig beim Abspielen auf die USB-Soundkarte “sysdefault-USB PnP Sounddevice” wohl nicht direkt auf Hardware abgespielt wird (Mixer Device hängt dazwischen).

Wenn du direkt auf die Hardware abspielen willst, funktioniert das in der Regel über den genannten Parameter “-o hw:0”, der in den Kommandozeilenparametern von Squeezelite eingefügt wird. Wichtig ist dabei, dass kein anderer Audioplayer oder Kodi aktiv ist, der ggf. das Audiointerface schon exklusiv für sich beansprucht und keine sonstigen Parameter in diesem Feld stehen.
Falls das nicht geht, gibt es eventuell eine Soundkartenoption, die etwas wie “hardware” oder “direct hardware output” im Namen enthält und gewählt werden kann.

Weitere Möglichkeiten:
– ein regelmäßger Reboot, um dem Audioproblem zuvor zu kommen (ggf. erstelle ich hierfür mal ein Plugin). Aktuell müsste der Reboot in die Crontab eingetragen werden (z.B. für 6 Uhr morgens)

# Crontab Editieren über crontab -e
0 6 * * * sudo /sbin/reboot

– Nutzung von HifiBerry / IQAudIO / Justboom Karten, die alle fehlerfrei funktionieren statt der USB-Soundkarte (ggf. liegt es auch am USB selbst oder an der Stromzufuhr)
– Umstellen der Audioausgabe auf Pulseaudio (Autostart Desktop aktivieren und Audioausgabe auf Soundkarte “Pulse”/”Pulseaudio” setzen)