Reply To: Is there something working on max2play?

2. September 2016 at 1:50 #22836

After many (so many) times, I was able to get the audio (USB & BT) configured, wifi, jasper (I only tested the tts, not stt) etc etc
So I made an image to not start over every time.

Now I still have two one problems:
1) fails to install anything that comes from Git (in general with https port 443)
Connect to github.com (github.com) | 192.30.253.112 |: 443 ... failed: No route to host.
I have no proxy and nameserver in resolv.conf is ok (8.8.8.8 & 8.8.4.4)

SOLVED.
I found changes on the interfaces file (???)
2) if I install Rpi display for adafruit 2.8 the screen remains blank
SOLVED.
a) There was a link behind the display that had broken away
b) In max2play wabapplication I always read “RPi-Display Touchscreen Setup”.
This is because in rpitouchdisplay/controller/Setup.php there is:
`private function getAddonVersion(){
if(strpos($this->getConfigFileParameter(‘/boot/config.txt’, ‘dtoverlay’), ‘rpi-display’) !== FALSE || strpos($this->getConfigFileParameter(‘/opt/max2play/options.conf’, ‘display’), ‘7inch’) !== FALSE){
$this->view->installed = true;
}else{
$this->view->installed = false;
}
return true;
}`
with only rpi-display and 7inch. Missing pitft28r

In if condition, I added: strpos($this->getConfigFileParameter('/boot/config.txt', 'dtoverlay'), 'pitft28r') !== FALSE ||

Sorry for the English, just to explain what I’m doing:

4 raspberry , 5 rooms.
In every room there is a raspberry with squeezelite (the server is on a PC).
Only one raspberry has multisqueeze to run on two rooms (one with bluetooth speaker)
In one room, raspberry will also work with kodi.
I add a picture that is better than how I write in English
Red color is that I have yet to.
And, as I said, for now, I tested only tts, not stt

Raspberry schema

After I will be happy to share with you my plugin.

  • This reply was modified 3 months ago by  Arianna.
  • This reply was modified 3 months ago by  Arianna.
  • This reply was modified 3 months ago by  Arianna. Reason: solved route problem
  • This reply was modified 3 months ago by  Arianna. Reason: solved diaply problem