Reply To: No Output from Wolfson Card

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI No Output from Wolfson Card Reply To: No Output from Wolfson Card

4. July 2016 at 17:41 #21164

I’ve come to the forum for a solution to the same problem. I’m using the CirrusLogic card with v 2.26 of Max2Play on a Pi B+. I have not updated since installing the image. I’ve bought a licence and activated it, installed the advanced Raspberry settings and tried to configure the CirrusLogic soundcard. I have a screen attached and I noticed after saving the Cirrus card under Raspberry settings there’s the following in the log:

[info] Loading kernel module snd-bcm2835.
[ 13.974000] snd-rpi-wsp sound: ASoC: CODEC DAI wm5102-aif1 not registered
[ 14.0164131] snd-rpi-wsp sound: Failed to register card: -517

The second two lines then repeated.

When I “Change Soundoutput for Wolfson Audiocard” and choose “Playback to headset”, then save, I get:

” amixer: Control hw:sndrpiwsp open error: No such device

…. {repeated 9 times}

Updated Alsa Settings ”

Playing a sound file I hear it played through my screen speakers via hdmi, but nothing on my headphones plugged into the Cirrus card.

I know the card is ok as I’ve had it working with HiassofT’s patch for LibreELEC. But I tried the Max2Play image as it promised straightforward functionality with the Cirrus Card, as well as more advanced options. But no such luck in my case.

What next?