Reply To: [SOLVED] Equalizer

19. June 2016 at 1:01 #20735

SOLVED!

I was having the same problem as many: the equalizer just would not work with my HiFiBerry AMP+. After much web research and testing, I found the problem is in the alsa config file (/etc/asound.conf). Here’s how to fix the problem:

To find out what sound cards you have on your system, display the contents of /proc/asound/cards:

`$ cat /proc/asound/cards
0 [ALSA ]: bcm2835 – bcm2835 ALSA
bcm2835 ALSA
1 [sndrpihifiberry]: snd_rpi_hifiber – snd_rpi_hifiberry_amp
snd_rpi_hifiberry_amp`

Here you can see my HifiBerry Amp+ is seen as card 1. However the ALSA configuration file (/etc/asound.conf) is pointing to card 0, the default card:

$ cat /etc/asound.conf
ctl.!default {
    type hw
    card 0
}
pcm.equal {
    type plug;
    slave.pcm plugequal;
}
ctl.equal {
   type equal;
   module "Eq10";
}

pcm.plugequal {
   type equal;
   module "Eq10";
   slave {
     pcm "plughw:0,0";
   }
   hint {show on;description "Equalizer for plughw:0,0"}

To fix the problem, you need to change all references in /etc/asound.conf from card 0 to your card (1, in my case). Here is my corrected /etc/asound.conf:

$ cat /etc/asound.conf
ctl.!default {
    type hw
    card 1
}
pcm.equal {
    type plug;
    slave.pcm plugequal;
}
ctl.equal {
   type equal;
   module "Eq10";
}

pcm.plugequal {
   type equal;
   module "Eq10";
   slave {
     pcm "plughw:1,0";
   }
   hint {show on;description "Equalizer for plughw:1,0"}

Now reboot your machine, then go into the Max2Play Audio Player->Advanced Configuration. Change the Sound Card to “plugequal – Equalizer for plughw:1,0”. I also changed my ALSA Parameters to “80:::” and the Command Line Options to “-r 44100-48000 -u hL::::”.

Save everything, reboot again, and you should be good to go.

Warning: I have a very basic system; just a stock RPi2 and a HiFiBerry AMP+. If your system has additional hardware or a different amp/DAC, your mileage may vary, but the basic approach should get you where you need to go.

Hope this works as well for everyone!

  • This reply was modified 1 year, 3 months ago by  HandyGuy.