Reply To: Statisch IP auf eth0 funktionieret nicht

9. April 2016 at 11:42 #19721

PS. Mir ist gerade aufgefallen das der RaspBerry Pi jetzt über zwei Adressen (.32 und .57) ansprechbar ist, das ist etwas verwirrend.
Ich weiß auch nicht ob das jetzt am max2play Image oder an meiner FritzBox liegt.
Hat jemand einen Tip wie ich das hin bekomme, oder würde es genügen die interfaces wieder auf urzustand zu setzen und den Eintrag in der ifplugd config zu ergänzen?
Dazu müsste ich aber wissern welcher Eintrag das ist.

PS: Habe eine Lösung gefunden, das hat dann geholfen:

update-rc.d dhcpcd disable
service dhcpcd stop
ip addr del %YOURS-SECOND-IP% dev ethX

in meinem Fall also

update-rc.d dhcpcd disable
service dhcpcd stop
ip addr del 192.168.178.57/24 dev eth0

anschließend den Pi neu starten.

  • This reply was modified 5 years, 2 months ago by  hansi9990.
  • This reply was modified 5 years, 2 months ago by  hansi9990.