Reply To: Synology NAS Mount Error: "mount.nfs: Failed to resolve server"

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Synology NAS Mount Error: "mount.nfs: Failed to resolve server" Reply To: Synology NAS Mount Error: "mount.nfs: Failed to resolve server"

10. December 2015 at 11:22 #17223

Stefan,

Thank you for replying. I have tried what you suggested and to my suprise it worked!!

It seems to me that the help instructions on the Filesystem Mount page are somewhat misleading, the fact they use Synology as the example is even more confusing.

I actually managed to get this working using the NFS permissions locked to the IP address of my Raspberry Pi, however I have taken on Claudio’s advice and used a * wildcard instead of a static IP address as my Raspberry Pi is being served a DHCP address.

So I now receive a message back saying the mount has been succesful. However if I open up the Squeezebox Server settings and look for the newly created folder /mnt/mountdir it isn’t there.

I am able to locate the /mnt folder but there is only one other folder shown in there which is /mnt/mpd. I have attempeted to point the server at both locations and performed a rescan. Unfortuantly the server does not find any music at all. Interestingly if I VNC into the Pi and navigate to /mnt/mountdir the folder can be seen but it is empty. What is going on here? See pic…

Edit: for some reason I couldn’t insert the picture. here is a link.. http://postimg.org/image/d63qwci2j/

Thanks in advance.

Olly.

  • This reply was modified 1 year, 9 months ago by  Olly_RPM. Reason: Unable to embedd screen grab