Reply To: cannot see external hard drive

10. December 2015 at 10:36 #17222

Hi Fred

Wow, thanks for your help, which is as I said very very kind of you.

Just realised if you have 1.2TB of music/data thats a huge amount of data, wow, I’m impressed actually !
I have about 500gb at the moment on the squeezeplug which I have hooked up to a logitech touch and which works without a glitch and has done for quite a while.

And indeed your last reply has got me thinking because now I have read it. it looks like I was’nt doing things right, read on !

On my M2P, I have seen in the filesystem mountpoint Media/USB0 so thats ok, this is why I guess I can see the actual files if I look using the Pi file manager
But what I don’t see or have ever seen is the “Path UUID=F474B7AA74B76DCC”
Maybe this is been prevented because of that power/clicking issue?

So where did “UUID=F474B7AA74B76DCC” come from, was it loaded automatically, I think you’re going to say it was ?

Ok, now I come onto the other bits.

It says on the M2P site “If it (music I guess) is stored on a USB-drive this will be mounted automatically to /media/usb and /media/usb0.”
So I took it that I had to do nothing more. Meaning I didn’t have to write in the paths (which I thought was a bit odd at the time but hey ho).. So I just carried on. (bet you are screaming “you dope” at the monitor at this point..)

After trying for quite a few hours to get it to work, I was no closer and then started to think if it was indeed right to leave it blank.

Well, we all know that conventional drives just auto mount and things then can be found and run from them. Well, this was my logic with this Pi at this stage.

Now, seeing what I see here has certainly blown that theory out of the water even though I have tried to put the paths in, and in various conbinations and still not got no further. And you know what Fred, I was drawn to the conclusion it could be a path issue from the start maybe it is but now its also the power issue too.

So going back to what you have in your path(s)..

1. The filesystem mount, if this is done when you connect up with no input from you, well there’s an issue there I have
2. Samabashares mine is blank at the moment but I have put in several paths in the past to no avail but I’ll try again as long as I can get 1 done above
3. In Squeezebox mine is blank again, but you have /media/usb/MUSIC, mines blank, so I’ll try that too writing the path to my own music folder, of course….
4. Where actually did you write this in squeezeplug, under what heading ?

All these, and I’m sorry for sounding stupid Fred, you accessed via the M2P GUI ?, You Must have.
You did’nt use a text editor or anything like that ?

And yes Logic is telling me M2P MUST work…and I hope it does as I really don’t want to use the other older Pi I have bought which will be running squeezeplug. But worse case is, if I have to then I will.. But here’s hoping.

well, Looks like its going to be busy but I hope a fruitful weekend ahead, and albeit I say weekend, once started I hope just a few hours. Well it beats christmas shopping 🙂
Gosh I sound like “Ebenezer Scrooge”…

Fred, I don’t know you but what a decent chap, thanks for your support and help and fingers crossed, it will get sorted, errr well I’ll not tempt fate just yet
hahahah
Thanks Fred

Alex