Reply To: MAx2Play Problems on Odroid XU4

Max2Play Home 2016 (en) Forums Max2Play on ODROID U3/C1 MAx2Play Problems on Odroid XU4 Reply To: MAx2Play Problems on Odroid XU4

24. September 2015 at 12:49 #15799

Hi Alex,

good to hear you got the SPDIF USB-DAC working! If kodi is set to autostart and squeezelite tries to access the same audio device (e.g. your USB-DAC) there will always be problems because kodi uses pulseaudio and squeezelite uses alsa.

If your email address is not recognized for a valid license there may be a problem with your internet connection or our server. You might try this: remove the email address -> click save -> insert email address again and save. If it is still not working please send us a mail with your address and we will check this.

The expansion of SD-cards is not too easy to build fail safe… If a user doesn’t know about the names in a selection this might cause some confusion. As for now, the easiest way is to make sure no other storage device is plugged in just click “expand filesystem”.

Problems with kodi should be discussed on the Hardkernel forum page as there are the experts who modified Kodi in some ways to work with the ODROID hardware. If you encounter issues you might find help on their page.

I built the PVR-Addons and Kodi for the U3 and also tried this on the XU4 but ran into problems with starting my compiled kodi. If you want to try to compile kodi on the XU4 and also compile the PVR-Addons this is what I did to compile everything (maybe you get it working? I am not that expert in Kodi development but will try it again if i find some time for it…):

# Packages
sudo apt-get install automake bison build-essential cmake curl cvs libJsonCpp-dev default-jre fp-compiler gawk gdc gettext git-core gperf libasound2-dev libass-dev libboost-dev libboost-thread-dev libbz2-dev libcap-dev libcdio-dev libcurl3 libcurl4-gnutls-dev libdbus-1-dev libenca-dev libfontconfig-dev libfreetype6-dev libfribidi-dev libglew-dev libiso9660-dev libjasper-dev libjpeg-dev liblzo2-dev libmad0-dev libmicrohttpd-dev libmodplug-dev libmpeg2-4-dev libmpeg3-dev libmysqlclient-dev libnfs-dev libogg-dev libpcre3-dev libplist-dev libpng-dev libpulse-dev libsdl-dev libsdl-gfx1.2-dev libsdl-image1.2-dev libsdl-mixer1.2-dev libsdl2-dev libsmbclient-dev libsqlite3-dev libssh-dev libssl-dev libtiff-dev libtinyxml-dev libtool libudev-dev libusb-dev libvdpau-dev libvorbisenc2 libxml2-dev libxmu-dev libxrandr-dev libxrender-dev libxslt1-dev libxt-dev libyajl-dev mesa-utils nasm pmount python-dev python-imaging python-sqlite swig unzip yasm zip zlib1g-dev autopoint ccache libavfilter-dev libbluetooth-dev libbluray-dev libcwiid-dev libcwiid1 libmp3lame-dev libpostproc-dev libsamplerate0-dev libswscale-dev libtag1-dev libva-tpi1 liblockdev1 liblockdev1-dev checkinstall doxygen libtag1-dev libgif-dev libgnutls-dev -y

# IMPORTANT ON XU4: /usr/lib/arm-linux-gnueabihf/mali-egl/libglesv2.so verlinken in /usr/lib/arm-linux-gnueabihf/ statt mesa-egl !!!

# KODI latest from Owersun Repository
cd /opt
git clone https://github.com/Owersun/xbmc.git -b Isengard
cd xbmc
./bootstrap
./configure --enable-x11 --disable-pulse --enable-alsa  --enable-neon --disable-debug --enable-optimizations --enable-ccache --enable-gles --enable-non-free --enable-exynos5 --disable-gl --disable-vdpau --disable-vaapi --disable-crystalhd --disable-openmax --disable-joystick --disable-rsxs --disable-projectm --disable-fishbmc --enable-nfs --disable-afpclient --disable-dvdcss --disable-optical-drive --disable-libbluray --enable-texturepacker --host=armv7a-hardfloat-linux-gnueabi --with-platform=samsung-exynos --with-cpu=cortex-a9 --prefix=/usr/local

FFMPEG_CFLAGS="-march=native -mfloat-abi=hard -mfpu=neon -ftree-vectorize -mvectorize-with-neon-quad -ffast-math -mcpu=cortex-a9 -mtune=cortex-9 -O3 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2" CFLAGS="-march=native -mfloat-abi=hard -mfpu=neon -ftree-vectorize -mvectorize-with-neon-quad -ffast-math -mcpu=cortex-a9 -mtune=cortex-a9 -O3 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2" CXXFLAGS="-march=native -mfloat-abi=hard -mfpu=neon -ftree-vectorize -mvectorize-with-neon-quad -ffast-math -mcpu=cortex-a9 -mtune=cortex-a9 -O3 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2" make -j8

# create .deb file
checkinstall

# Fix für Bild, das nicht angezeigt wird (Fehler bei Kodi Start)
rm -R /usr/lib/arm-linux-gnueabihf/mesa-egl/

####### PVR Addons Isengard von Liste https://github.com/kodi-pvr  #############
# Zuerst Kodi Plattform installieren und VORHER kodi in Version 15.1 kompilieren / installieren
cd /opt
git clone https://github.com/xbmc/kodi-platform.git
cd kodi-platform
cmake -DCMAKE_INSTALL_PREFIX=/usr/local
make && sudo make install

# Platform installieren: http://forum.kodi.tv/showthread.php?tid=220990&pid=2013039
cd /opt
git clone https://github.com/Pulse-Eight/platform.git
cd platform
cmake -DCMAKE_INSTALL_PREFIX=/usr/local
make && sudo make install

# Addons creation
# Select your Plugins to build
PLUGINS=( "pvr.hts" "pvr.iptvsimple" "pvr.stalker" "pvr.demo" "pvr.dvbviewer" "pvr.dvblink" "pvr.vuplus")

mkdir /opt/pvrplugins
mkdir /opt/pvrplugins/build
pushd /opt/pvrplugins

for PVRPLUGIN in "${PLUGINS[@]}"
do
	pushd /opt/pvrplugins
	echo "Build $PVRPLUGIN"
	git clone https://github.com/kodi-pvr/$PVRPLUGIN.git --branch=Isengard
	pushd /opt/pvrplugins/$PVRPLUGIN
	cmake -DCMAKE_INSTALL_PREFIX=/usr/local
	make
	make install
	cp pvr.* $PVRPLUGIN/
	# ACHTUNG Versionsnummer muss in Zipfile stehen: $PVRPLUGIN-$VERSION.zip
	VERSION=$(grep -i "^\s*version=" $PVRPLUGIN/addon.xml | grep -o "[0-9\.]*")
	zip -r $PVRPLUGIN-$VERSION.zip ./$PVRPLUGIN
	cp $PVRPLUGIN/addon.xml .
	cp $PVRPLUGIN-$VERSION.zip /opt/pvrplugins/build 
done

Cheers,
Stefan