[SOLVED] Network issues with Squeezebox plugins related to netmask

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Network issues with Squeezebox plugins related to netmask

This topic contains 4 replies, has 3 voices, and was last updated by  j_cuddihy premium 5 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 31. Dezember 2016 at 19:57 #25340

    Hello all

    after the installation of the jessie image, the deezer plugin was unable to stream anymore while the radio plugin was working fine.
    It took some time to figure out that the netmask was restricted to by the max2play configuration. Changing it to in /etc/network/interfaces fixed the issue.

    I’m running max2play on a RPI 2 with a fixed LAN IP setup (e.g.

    Why is the netmask restricted by default?

    Best regards

    2. Januar 2017 at 18:35 #25368

    Thanks for pointing me towards this solution – it solved my issue also.

    Much appreciated,


    10. Oktober 2017 at 13:29 #31848

    How did you change the netmask please?

    10. Oktober 2017 at 13:47 #31849

    Hi H,
    It’s been a while since I did it, but as far I remember, I logged on to the Pi using Putty, went to the directory outlined above, and edited the file. If this isn’t clear to you, I’ll log on again tonight and outline a step by step process for you.


    16. Oktober 2017 at 20:14 #31909

    ok – So go into PuTTY, log in to the device using the IP address and login credentials. then goto the etc folder (cd /etc) then the network folder (cd network) and edit the interfaces file (vi interfaces). You will see several lines down there is a line that starts with netmask. Set this to netmask and quit and save the file (:x). Then just close the puTTY session. That should do it.



Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here