[SOLVED] M2P 2.34/2.36, RPi 3 and Wolfson/Cirrus card.

Max2Play Home Forums Max2Play on Raspberry PI [SOLVED] M2P 2.34/2.36, RPi 3 and Wolfson/Cirrus card.

Viewing 10 posts - 1 through 10 (of 10 total)
  • 22. September 2016 at 16:57 #23161


    Could someone from M2P please confirm the latest version of M2P that will support the Wolfson/Cirrus card on RPi3?

    I am able to get the combination working by installing from M2P 2.31 then upgrading to 2.36. If I start installing at 2.34 the install does not work after I select the Wolfson/Cirrus card in ‚Raspberry Settings‘ and reboot. Is this what Flysurfer/Stefan was referring to when he wrote the following in a previous topic?

    „once you change the Kernel on the Max2Play Image to support the Wolfson/Cirrus card, it won’t run anymore because the Kernelchange was only working with the older “debian wheezy” based Max2Play version (you may still download this version on our page). I also removed this option in the newest version from the Raspberry Pi Settings Addon.“

    Also, could you please tell me exactly what is meant by, „I also removed this option in the newest version from the Raspberry Pi Settings Addon“ as I can still see the Wolfson/Cirrus card as an option in „Raspberry Settings“ in 2.34 and 2.36, even though it appears not to work?



    30. September 2016 at 11:39 #23266

    Hi Simon,

    the Wolfson card drivers and the driver selection within „Raspberry Pi Settings“ should work with the current Max2Play Image. We will test this again with the latest version. EDIT: ok – there seems to be a problem with the newer Kernel… we work on this.


    • This reply was modified 7 years, 8 months ago by flysurfer.
    4. Oktober 2016 at 1:09 #23273

    Hi Stefan,

    Thank you for the update. I am very happy to hear that the Cirrus/Wolfson card is still part of M2P’s future.

    Keep up the great work.


    9. Oktober 2016 at 10:43 #23322

    Hi gapmedia,

    I am running Cirrus/Wolfson on version 2.37 with kernel 4.4.

    After kernel update the card was gone at first. I then installed it via m2play web interface and it did NOT work.
    Then I selected NONE as card, saved and rebooted and strangely the Cirrus was there.
    Do not know if this can be repeated, because I do not want to break it again…


    10. Oktober 2016 at 12:30 #23335

    Hi Mike / hi Simon,

    the fix for the wolfson/cirrus logic card in the current version of Max2Play (version 2.37) uses a newer Kernel that fits the latest Max2Play-Image and uses a renamed Device Tree Overlay for the card.

    This definitly works when using the latest Max2Play-Image -> Install Wolfson-Card on Raspberry Settings Tab -> Reboot -> choose Card in Audioplayer Tab (advanced Settings) and set prefered Audio-Output on Raspberry Settings Tab.

    Older Max2Play-Images should still work, as the Bugfix just targets the latest Max2Play-Image based on Kernel 4.4.y

    : After installing the Wolfson-Card with the Kernelchange, the change of the installed soundcard to „none“ doesn’t change the Kernel back to the original one. But it removes the DTOverlay entry to load the card on boot. If your card won’t work after the next reboot, make sure to select it again.

    All the Best

    11. Oktober 2016 at 1:30 #23363

    Hi mike and Stefan,

    Mike, thanks for your reply. Seems 2.37 fixes things.

    Stefan, that is great news. Unfortunately, „the current version of Max2Play (version 2.37) uses a newer Kernel that fits the latest Max2Play-Image and uses a renamed Device Tree Overlay for the card.“ is all a bit above me technically, and that is why I love your M2P, it works and lets me do things with a RPi that I wouldn’t be able to without it. Maybe it is time or me to try and learn about DTO’s and Kernels.

    I have updated to 2.37 and all is still working, but I noticed under debug on the Settings/Reboot page that I am on Kernel 4.1.13, is this okay or should I update to Kernel 4.4.y that you mention below? How would I do this? Re-select the Wolfson/Cirrus card under Raspberry Settings and reboot?

    Debug info: Linux xxxx 4.1.13-v7+ #1 SMP PREEMPT Sat Nov 21 12:39:03 CET 2015 armv7l GNU/Linux

    I still see at the bottom of the Raspberry Settings page, ‚Upgrade to latest Kernel (breaks Wolfson Audio cards!):‘ Does this still apply, or this how to get to Kernel 4.4.y?


    3. November 2016 at 18:06 #23656

    Dear gapmedia,

    Sorry for the late response.

    If the Cirrus Logic soundcard already works, you don’t need a kernel upgrade.

    17. November 2016 at 16:47 #23949

    Thank you Christoph.

    18. Dezember 2016 at 22:52 #24980

    Sorry for being a newbie, but do you need to have a license for enabling a cirrus audio card, or am I doing something wrong here.
    Selecting the cirrus card in the RPi settings and rebooting don’t result in a detected cirrus card…
    Only after manual adding the kernel update it makes the card at least detected by the RPi, but can’t find any option to use the card as an output device… Any hints available??

    19. Dezember 2016 at 11:47 #24983

    Hi Wallie,

    sorry, but if you don’t have a Max2Play license the „Raspberry Pi Settings“ Page will not work. This is indicated with the message output above the content („License needed…“). You probably noticed that nothing gets saved when you try to change any values on the page. You may try the 3 month license of Max2Play to set up everything you need.

    All the Best,

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Register here