Cannot Stream the Line In from HiFiBerry DAC – ADC through Squeezbox Server

Max2Play Home Forums Max2Play on Raspberry PI Cannot Stream the Line In from HiFiBerry DAC – ADC through Squeezbox Server

Viewing 27 posts - 1 through 27 (of 27 total)
  • 14. Mai 2020 at 18:18 #48783

    I have got my DAC – ADC setup on a Pi 4 and have the Analogue output from my TV Amp playing into the 3.5mm Socket on the HiFiBerry Board. I can play music from my Music server running Logitechmediaserver, no problem. The same Output works fine on my Sonos Device (I am trying to move away from Sonos) so I know there is output there.
    I have setup Squeezebox from here with the url as wavin:sysdefault and confirmed the same URL as in ‘AudioPlayer – Squeezelite – Advanced Options – Soundcard’ setting.
    I have the DAC – ADC selected in the ‚Installed HiFiBerry Card‘ so it should work, but it does not.
    Should I increase the sensitivity using the J1 on the board or what?

    15. Mai 2020 at 11:25 #48788

    Problem with Audio Out as I see it:

    HiFiBerry Tab – Installed Card = DAC+ ADC

    AudioPlayer Tab – Audio Output on Raspberry Pi = Default (use HDMI if Plugged)

    Raspberry Settings – Choose the DAC/AMP = none This cannot be correct

    So change as follows:

    Setting the DAC+ ADC is not possible in the Raspberry Settings it is missing, so if you choose the DAC+ Pro

    Raspberry Settings – Choose the DAC/AMP = DAC+ Pro

    HiFiBerry Tab – Installed Card = DAC+ Pro is chosen automatically which is not correct

    Reboot still no sound out to Cottage

    I think the problem lies in the DAC+ ADC not showing in the Raspberry Settings – Choose the DAC/AMP

    How can I make this show up?

    15. Mai 2020 at 14:42 #48792

    Hi themetman,

    In the Wave Input Plugin of the Squeezebox Server you should be able to set the corresponding ALSA input of the ADC sound card. The input signal should have a separate name. If this is set correctly, it should work. You may only be able to select the ADC driver via the HiFiBerry plugin, not via the Raspberry settings. It shouldn’t be a problem that afterwards no output is shown in the Raspberry Settings.

    15. Mai 2020 at 15:05 #48795

    @MarioM thanks for the quick response.
    I have selected the HiFiBerry Tab – Installed Card = DAC+ ADC and rebooted.
    Then the AudioPlayer Squeezbox Advanced Options - Soundcard = sysdefault - snd_rpi_hifiberry_dacplusadc so it should work.
    The tail end of my /boot/config.txt file is as follows

    # Enable DRM VC4 V3D driver on top of the dispmanx display stack

    So the Correct card should be loaded.
    Now I open the Logitechmediaserver and select the Line In which is configured to use this
    wavin:sysdefault which matches the setting above. I have the other HiFiBerry device as the Player and still no sound.
    If I play sound from my Music server using the Logitechmediaserver on there, I can get the music synchronised out of both my Pi Devices, so they are working, but not for the Line In.
    For my setup it is essential that the Line In works.
    Any more ideas?

    19. Mai 2020 at 15:52 #48812

    Hi themetman,

    I’ll be back in the office tomorrow. If I have the time, I will test the setup myself and contact you again.

    20. Mai 2020 at 16:29 #48823

    Hi themetman,

    I was able to successfully test the input of the HiFiBerry ADC with the Wave Input Plugin. Please try to enter „wavin:plughw:1“ as URL in the plugin. Depending on which slot your sound card has been assigned to, „wavin:plughw:0“ may also be possible. It is best to check this with the command „arecord -l“ (small L) in the terminal or in our Remote Control Plugin.

    If there are interruptions when synchronizing the players, you can increase the buffer size in the LMS under Settings/Advanced/Network/Radio Station Buffer.

    21. Mai 2020 at 9:40 #48830

    @MarioM thank you for taking the time to test this for me. I still cannot get it to work.
    I have setup the Server in the LivingRoom and I have the Player in the Cottage.
    In the LivingRoom:
    From arecord -l

    **** List of CAPTURE Hardware Devices ****
    card 1: sndrpihifiberry [snd_rpi_hifiberry_dacplusadc], device 0: HiFiBerry ADCDAC+ Pro HiFi multicodec-0 []
      Subdevices: 1/1
      Subdevice #0: subdevice #0

    In AudioPlayer – Advanced Options there ate three entries starting plughw, two refer to the bcm2835 on the Pi one as Card=ALSA,DEV=0 and the other as Card=ALSA,DEV=0 the other refers to the HiFiBerry Cars as Card=hifiberrydacplusadc,DEV=0
    I have also added this -b 176400:176400 to the Command Line Options, without this I get nothing at all.
    I have selected the last of these and in the Squeezebox Server I have tried this wavin:plughw:0 and this wavin:plughw:1 but no sound from the other device.
    Also Squeezebox will only run for a very brief few seconds and stops.
    Then I changed the AudioPlayer – Advanced Options to default – snd_rpi_hifiberry_dacplusadc and in the Squeezebod server wavin:default did not play, so tried wavin:default:0 the same, then wavin:default:1 did play but just white noise.
    I do have it working perfectly in piCorePlayer by the way which I tried when I could not get Max2Play working. I am only pursuing this in case others are in a fix.

    22. Mai 2020 at 14:21 #48832

    Hi themetman,

    In my setup I selected „sysdefault … hifiberrydacplusadc …“ in the advanced settings of Squeezelite. I only entered „wavin:plughw:1“ as URL in the Wave Input Plugin of the Squeezebox Server. Do you have other services running on the Pi that use the sound card? I switched off Shairport for example. Incidentally, this setup only works if the Squeezebox Server is running on the device with the HiFiBerry DAC+ ADC.

    22. Mai 2020 at 16:37 #48835

    @MarioM, I have done as you say above. I do not have any other service running, not even SAMBA.
    The Squeezbox Server is running on the Raspberry Pi 4 with the DAC+ ADC on it.
    All I get is white noise with the hint of speech in the background.
    I get nothing if I change to wavin:plughw:0 in the URL of the Plugin.
    So looks like a non starter for me for some reason. Very odd.
    here is the debug Output:

    2020-05-22 15:31:48 squeezeboxserver_safe started.
    [20-05-22 15:31:52.3935] main::init (387) Starting Logitech Media Server (v7.9.2, 1578996832, Tue Jan 14 12:16:57 CET 2020) perl 5.028001 - arm-linux-gnueabihf-thread-multi-64int
    [20-05-22 15:31:52.8331] Slim::Utils::IPDetect::_init (138) Warning: Couldn't call connect() - falling back to
    [20-05-22 15:31:52.9306] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [20-05-22 15:31:53.0040] Slim::Schema::forceCommit (2143) Warning: Trying to commit transactions before DB is initialized!
    [20-05-22 15:31:53.2417] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [20-05-22 15:31:53.3202] Slim::Schema::forceCommit (2143) Warning: Trying to commit transactions before DB is initialized!
    [20-05-22 15:31:54.1787] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [20-05-22 15:31:54.1975] Slim::Schema::forceCommit (2143) Warning: Trying to commit transactions before DB is initialized!
    [20-05-22 15:31:54.4827] main::checkDataSource (1107) Warning: Schema updated or no media found in the database, initiating scan.
    [20-05-22 15:31:56.6871] Slim::Utils::SQLiteHelper::postConnect (377) Optimizing DB because of missing or empty sqlite_stat1 table
    [20-05-22 15:31:56.7069] Slim::Schema::forceCommit (2143) Warning: Trying to commit transactions before DB is initialized!

    Not very helpful, and nothing more in the system logs when I ssh into the server.

    27. Mai 2020 at 15:36 #48867

    Hi themetman,

    Do you have Bluetooth installed on your device? Apparently there was a problem with the Pi 4, LMS 8 and our Bluetooth installer. We have now integrated a fix for the installer in our beta image. If you uninstall and reinstall Bluetooth (and the Wave Input plugin) again, the Wave Input plugin should work properly again.

    27. Mai 2020 at 17:20 #48873

    Supplement to my last post:

    You probably have to install the Wave Input Fix on our Squeezebox Server page in the Max2Play webinterface (instead of simply uninstalling and reinstalling the plugin at the plugin overview).

    31. Mai 2020 at 11:45 #48886

    Thank you, @MarioM once again. I am running version m2p_buster_rpi-v250.img of the Max2Play OS. Is there another one I should be using?
    I do no have Bluetooth activated at all in the Settings/Reboot Section.
    I have removed the Plugin in the Squeezebox Server Interface.
    I have restarted the Squeezebox Server, and even Rebooted the device.
    I have tried at least 4 times to install the WaveInput Plugin like so:
    1. Check the WaveInput item near the bottom of the page, and click ‚Apply‘
    2. Wait until the ‚restart Now, restart later‘ Dialog box appears. and click ‚Restart Now‘
    3. wait for it to reappear

    It stubbornly refuses to install, so I installed version 104_7.6 manually from here to here /usr/share/squeezeboxserver/Plugins and restarted the Squeezebox Server and it showed up.

    I left the setting as this wavin:plughw:1 from before, and all I get is still white noise over speach or sound.

    I would like to use your Wave Input Fix on our Squeezebox Server page in the Max2Play webinterface but I cannot see it. It is not listed in the ‚Install special Plugins for Squeezebox Server‘ so I am stuck once again.

    2. Juni 2020 at 14:48 #48912

    Hi themetman,

    You can install the fix after you updated to our latest beta on the Settings/Reboot page.

    4. Juni 2020 at 10:37 #48940

    OK, @MarioM, so I have Version Beta-200602 installed now, I have uninstalled the WaveImput Plugin and reinstalled it, kept the same wavin:plughw:1 in the Squeezbox Server and plughw in the AudioPlayer – Advanced Options – Soundcard, but still just white noise.
    Please do not worry about this. I have it working fine in PiCorePlayer.
    I know it would be nice to get it working for the sake of anyone else having the same problem, which is why I have been persisting with this.

    4. Juni 2020 at 16:15 #48942

    Thank you themetman for supporting us in the search for a solution, despite the fact that you have already made it work with other software. If you are still motivated to do so, you could try the following (also serves as a kind of summary on this topic):

    Deactivate all audio players except Squeezelite, set the output there to „sysdefault … hifiberrydacplusadc …“ and install the Wave Input Fix on the Squeezebox Server page (not the SB Server Webinterface, but the plugin for Max2Play. You do not need to uninstall and reinstall the Wave Input plugin at the SB Server settings for this). At the SB Server webinterface, create a new favorite and enter „wavin:plughw:1“ as the URL. It may also help to deactivate the Pis internal audio on the Raspberry settings page. Then it may be possible that the sound card changes to hw:0 (adjust the URL accordingly). Again, to check which slot the sound card has been assigned to, use the command „arecord -l“ in the terminal or our remote control plugin. To test playback, connect a cell phone to the sound card with a mini jack cable and play music, then select the favorite you have just created for the SB Server and press Play there too.

    5. Juni 2020 at 8:50 #48945

    Thank you @MarioM I have done a fresh install.
    Setup the HiFiBery Card with „sysdefault … hifiberrydacplusadc …“
    Upgraded to Beta-200602.
    Installed Squeezebox Server and installed the WaveInput from the SB Server Page in the Max2Play Interface
    Added the „wavin:plughw:1“ to my favourites.
    Then set it to play on my other Pi, and guess what??????

    It Worked!!!!

    So we now have a method for anyone else out there with the same problem. Bit of a saga, but got there in the end.

    22. Juni 2020 at 17:01 #49063


    I am going to order a pi4 and a new DAC + ADC board and try this out. I have been looking for an elegant solution to having an analogue input for ages and this seems perfect.

    How many seconds is the lag of the sound?
    Are you having any distortion on the sound?


    29. Juni 2020 at 12:30 #49105


    I have successfully had a very quick play with this this morning on a PI4 and a hifiberry DAC +ADC. Unfortunately I have changed so many settings that I am not sure what has worked but I’ll try to summarize.

    -I installed MAX2Play (pi4 image)
    -Selected hifiberry from the popup for max2play
    -Selected the DAD+ADC card from the hifiberry tab in max2play
    -Installed Squeezebox server 7.9 nightly.
    -Realised that I needed the beta image – installed the BETA max2play update
    -Added the Waveinput plugin in squeezebox plugins
    -Tried adding a favorite with wavin:plughw:1 – lots of hiss.
    -Added the waveinput fix on the squeezebox server tab of max2play
    -Tried adding a favorite with wavin:plughw:1 – This time it wouldnt work at all. HMMM
    -Disabled the Bluetooth and normal audio of the pi in the Raspberry settings page
    – Changed the waveinput favorite address to wavin:sysdefault

    IT WORKED. Albeit with a 10-15 sec delay but its amazing progress for me. I am delighted that this is a possibility and the sound was perfect.

    I am now going to get back to homeschooling my kids and have a play at the weekend with a bit more effort and robustness. There is a blog by HiFi berry on how to get this working too so I may try that to see if the delay is better using a very basic install of LMS. I’ll then report back to the forum.

    Thank you so much guys for helping me get to this point.

    12. Oktober 2020 at 19:01 #49830


    What version of LMS do people have running please?
    I’m on 7.9.4 and doing everything that’s been mentioned here but I’m still getting white noise.

    M2P 200803, Waveinput installed from the M2P GUI, added url favorite…

    The beta’s looking good guys, thank you!

    14. Oktober 2020 at 14:32 #49845

    Hi kanetoad,

    The Wave-Input Plugin Fix was added for LMS version 8.0. With version 7.9, the usual installation of the wave input plugin should work. To rule out a hardware defect, please test streaming to the Squeezebox server via Bluetooth. This feature also uses the wave input plugin.

    28. September 2021 at 14:07 #51685

    I was finally able to get the wave-input plugin to work with my record player.

    I have two Max2Play’s running a Hifiberry AMP and a Hifiberry DAC-ADC. First I had the Squeezebox server running on the Hifiberry AMP, and the wave-input plugin did not work. I am reading that a few people have the issue that the plugin starts and then stops. That’s exactly what I had with my incorrect setup.
    What I didn’t realise was (MarioM mentions this) is that the Squeezebox Server has to be installed on the HiFiBerry DAC – ADC machine.

    These are the steps I took:

    1. I checked the card with arecord -l in the terminal and it gave me:
    card 1: sndrpihifiberry [snd_rpi_hifiberry_dacplusadcpro]
    –> therefore URL „wavin:plughw:1“
    2. In the LMS settings (IP:9000) under plugins checked the Waveinput (v1.04) , save and close.
    3. Created a favorite with the „wavin:plughw:1“
    4. Done and this works

    There is a 4-7 second delay when playing records. It’s a little weird , but it does work.

    30. September 2021 at 15:52 #51694


    I would just like to add an update that might help a few people diagnose problems with adding line in support in squeezebox with max2play.

    I thought that I had a problem getting this to work with WHITE NOISE however after ages of testing the reason that I was getting white noise is due to the fact that input on the Hifiberry DAC is Line Level. I was testing with a 3.5mm jack from my phone with the volume set too high. When I finally set the volume to its near lowest setting on my phone all the white noise disappeared and it now works perfectly.

    I am so glad that I got this working and without much fuss at all after I diagnosed the problem. My vinyl now has a new lease of life.

    I hope this helps others who have had the same issue.

    12. März 2022 at 23:38 #52124

    I tried the same thing with the HifiBerry DAC+ADC pro. It worked as well (plughw:0).

    I have taken LMS 8.20 and M2P 2.55.


    14. März 2022 at 1:14 #52126

    Is a preamp needed for Input of a turntable?

    15. März 2022 at 16:53 #52138

    Hi Hans,

    Yes, you should get the phono signal to line level with a preamp beforehand. See the ADC datasheet for more information on what is supported:

    17. März 2022 at 17:56 #52141

    One more question:

    Do I need to use an additional RPi for the input function?

    I am currently running a RPi using the USB output to an external DAC, so there is space for a HAT. I just wonder, if all (audio input of turntable & audio output via USB) can be done with one machine.

    Thank you for your feedback.

    22. März 2022 at 13:40 #52146

    Hi Hans,

    I’m afraid that’s not possible. You probably need two devices. Nevertheless, I would test it again myself when I get back to the office and let you know if it works or not.

Viewing 27 posts - 1 through 27 (of 27 total)

You must be logged in to reply to this topic.

Register here