Bluetooth Plugin — kein Ton

Max2Play Home 2016 (en) Forums Max2Play Add-ons Bluetooth Plugin — kein Ton

This topic contains 4 replies, has 2 voices, and was last updated by  MarioM Moderator 8 months, 3 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • 14. Februar 2020 at 9:40 #48026

    Hallo Max2Play-Team,

    ich benötige dringend Hilfe bei der Installation des Bluetooth Plugin.
    Installiert ist das Plugin auf einem Rasp. 3 mit der M2P Version 2.51. Ich bekomme weder Ton über den installierten Squeezeplayer noch über den LMS (7.9 Nightly).
    Folgende Dinge sind mir dabei aufgefallen:
    – Die Quelle (Handy) lässt sich richtig verbinden, schaltet auch den Ton über den eingebauten Lautsprecher ab.
    – Beim ersten Abspielversuch ist der Ton für ca. eine Sekunde zu hören. Das gilt für den Direktbetrieb über die Soundkarte als auch über den Betrieb über LMS. Danach ist kein Ton mehr zu hören, auch nicht, wenn ich die Verbindung trenne und erneut koppel.
    – Entgegen eurer Video-Beschreibung sind mir zwei Sachen aufgefallen: 1. Im „Direktbetrieb“ wird bei der Auswahl der Soundausgabe keine Ausgabe mit „PULSE …“ angeboten. 2. Beim Betrieb im LMS eischeine zwar unter „Favoriten“ ein Bluetooth Symbol, allerdings NICHT der Name des Handys. Die Zeitanzeige läuft zwar, aber wie schon erwähnt, kein Ton!
    Nachfolgend noch die beiden Debug Einträge (1. im Berieb über die Soundkarte / 2. über LMS)

    Wäre wirklich sehr nett, wenn mir jemand helfen könnte.

    Danke und VG Michael

    ——————————————————————————————

    1. Über Soundkarte

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: B8:27:EB:80:72:18 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN
    RX bytes:23311816 acl:40317 sco:103 events:629 errors:0
    TX bytes:15188 acl:433 sco:0 commands:170 errors:0

    #### DEVICE MICHAEL-NB ####
    [68:17:29:EC:CD:49]
    Name: MICHAEL-NB
    Alias: MICHAEL-NB [rw]
    Address: 68:17:29:EC:CD:49
    Icon: computer
    Class: 0x2a010c
    Paired: 0
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: [AudioSource, AVRemoteControlTarget, AVRemoteControl, HandsfreeAudioGateway, Handsfree]

    #### DEVICE HUAWEI P20 lite ####
    [C0:F4:E6:ED:FA:5C]
    Name: HUAWEI P20 lite

    —————————————————————————

    2. Über LMS

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: B8:27:EB:80:72:18 ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN
    RX bytes:23668841 acl:41012 sco:103 events:774 errors:0
    TX bytes:20318 acl:528 sco:0 commands:240 errors:0

    #### DEVICE MICHAEL-NB ####
    [68:17:29:EC:CD:49]
    Name: MICHAEL-NB
    Alias: MICHAEL-NB [rw]
    Address: 68:17:29:EC:CD:49
    Icon: computer
    Class: 0x2a010c
    Paired: 0
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 0
    UUIDs: []

    #### DEVICE HUAWEI P20 lite ####
    [C0:F4:E6:ED:FA:5C]
    Name: HUAWEI P20 lite
    Alias: HUAWEI P20 lite [rw]
    Address: C0:F4:E6:ED:FA:5C
    Icon: phone
    Class: 0x5a020c
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [0000046a-0000-1000-8000-00805f9b34fb, OBEXObjectPush, AudioSource, AVRemoteControlTarget, AdvancedAudioDistribution, HeadsetAudioGateway, PANU, NAP, HandsfreeAudioGateway, PhoneBookAccess, 00001132-0000-1000-8000-00805f9b34fb, PnPInformation, 00001800-0000-1000-8000-00805f9b34fb, 00001801-0000-1000-8000-00805f9b34fb, 0000fe35-0000-1000-8000-00805f9b34fb]

    #### BLUEALSA RUNNING ####
    1

    #### BLUETOOTH SQUEEZEBOX SERVER AUTOSTART ####
    Reading last 10 lines of /var/log/daemon.log
    Logfile was modified.
    Reading last 10 lines of /var/log/daemon.log
    Logfile was modified.
    Reading last 10 lines of /var/log/daemon.log
    Logfile was modified.
    Reading last 10 lines of /var/log/daemon.log
    Logfile was modified.
    Reading last 10 lines of /var/log/daemon.log
    Running – Start Stream on Squeezebox Server

    15. Februar 2020 at 9:00 #48029

    … kleine Ergänzung …
    Ich habe mittlerweile gelesen, dass der „PULSE-Player“ durch „Bluealsa“ ersetzt wurde. Aber auch der taucht in der Auswahl der Soundausgaben nicht auf. Auf der Oberfläche des WEB-Interfaces (unter dem Reiter Bluetooth) wird rechts in einem grün hinterlegtem Feld folgendes angezeigt:
    Einstellungen & Hardware
    Bluetooth-Dongle: verfügbar
    Bluealsa Running: 1

    Ergebnis bleibt immer das gleiche. Handy verbindet sich mit M2P aber kein Ton zu hören. 🙁
    Wäre wirklich sehr dankbar für einen guten Tip.

    Danke und VG Michael

    15. Februar 2020 at 13:21 #48030

    … hier nochmal die Debug Info nach einer neuen Installation. Ton war ca. 1 Sekunde zu hören, dann Stille …

    ————————————————–

    #### Bluetooth Installation ####

    #### Bluetooth Dongle ####
    hci0: Type: Primary Bus: UART
    BD Address: B8:27:EB:5B:1B:8A ACL MTU: 1021:8 SCO MTU: 64:1
    UP RUNNING PSCAN ISCAN
    RX bytes:683544 acl:1279 sco:4 events:240 errors:0
    TX bytes:8596 acl:125 sco:0 commands:124 errors:0

    #### DEVICE HUAWEI P20 lite ####
    [C0:F4:E6:ED:FA:5C]
    Name: HUAWEI P20 lite
    Alias: HUAWEI P20 lite [rw]
    Address: C0:F4:E6:ED:FA:5C
    Icon: phone
    Class: 0x5a020c
    Paired: 1
    Trusted: 1 [rw]
    Blocked: 0 [rw]
    Connected: 1
    UUIDs: [0000046a-0000-1000-8000-00805f9b34fb, OBEXObjectPush, AudioSource, AVRemoteControlTarget, AdvancedAudioDistribution, HeadsetAudioGateway, PANU, NAP, HandsfreeAudioGateway, PhoneBookAccess, 00001132-0000-1000-8000-00805f9b34fb, PnPInformation, 00001800-0000-1000-8000-00805f9b34fb, 00001801-0000-1000-8000-00805f9b34fb, 0000fe35-0000-1000-8000-00805f9b34fb]

    #### BLUEALSA RUNNING ####
    2

    24. Februar 2020 at 9:20 #48063

    … mittlerweile habe ich es geschafft zumindest die „direkte“ BT – Wiedergabe auf die Soundkarte zu realisieren.
    Ich habe ein altes Image (2.47) genommen und es damit mal versucht. Siehe da, hat sofort reibungslos funktioniert. Danach Update auf 2.51 sowie LMS (7.9 Nightly) installiert, alles weiterhin OK. Was ich allerdings nicht geschafft habe ist die BT-Wiedergabe über den LMS. Was muss ich dabei beachten? Bin mir z.B. nicht sicher ob ich „Bluetooth-Speaker“ abschalten soll oder weiterlaufen muss? Vielleich kann mir da jemand weiterhelfen.

    Im Anschluss habe ich die Grund-Installation, rein interessehalber, wieder mit dem neusten Image (2.49) von der M2P Homepage versucht. Ergebnis; Verbindung funktioniert aber KEIN TON …! Kann es evtl. sein, dass es diesbezüglich einen Bug bei der aktuellen 2.49 gibt? Vielleicht hat noch jemand diese Beobachtung gemacht?

    Danke und VG
    Michael

    11. März 2020 at 14:39 #48145

    Hallo Michael,

    Bitte entschuldige die späte Antwort.
    Schalte den Bluetooth-Speaker bei der Nutzung mit dem Squeezebox Server am besten aus, um mögliche Überschneidungen zu umgehen. Das von dir geschilderte Problem konnten wir bislang leider nicht reproduzieren. Bei unseren Tests konnten wir keine Unterschiede zwischen der Version 2.49 und 2.51 feststellen, wobei wir in der v2.50 diverse Bugfixes für Bluetooth integriert haben. Wir empfehlen generell die Nutzung der aktuellsten Max2Play Version bei der Nutzung von Bluetooth. Hier unsere grobe Vorgehensweise beim Testen:

    1. Bluetooth Plugin installieren
    2. Smartphone verbinden
    3. Bluetooth Speaker starten
    4. Wiedergabe auf dem Smartphone starten –> Streaming funktioniert
    5. Bluetooth Speaker stoppen
    6. Squeezebox Server (Nightly) installieren
    7. Bluetooth für Squeezebox Server installieren
    8. Weboberfläche des Servers öffnen
    9. Play-Button neben dem Bluetooth Plugin klicken
    10. Wiedergabe auf dem Smartphone starten –> Streaming funktioniert

    Hier der Wiki-Artikel zum Thema: https://www.max2play.com/en/wiki/bluetooth-direct-stream/

    Bitte überprüfe noch einmal, ob irgendwelche Dinge deine Bluetooth-Verbindung stören könnten (z.B. gleichzeitig laufendes WLAN-Interface).

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Register here