Reply To: External USB drive Formatted exfat plugged into Raspberry Pi 3b NOT mounting

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI External USB drive Formatted exfat plugged into Raspberry Pi 3b NOT mounting Reply To: External USB drive Formatted exfat plugged into Raspberry Pi 3b NOT mounting

3. September 2022 at 11:01 #52386

@mariom — Thank you very much for your response. (there is a problem with the Max2Play forum posting software not allowing edits to posts)

Yes indeed, I had tried the commands you suggested via VNC login and root terminal:
„sudo apt-get install exfat-fuse“
„sudo apt-get install exfat-utils“

Both commands generated errors indicating exfat-fuse was already installed as the latest version and would not be updated, however another puzzling error message implied that exfat-fuse required manual installation, which I was not able to do. Command „modprobe fuse“ indicated the fuse module was either not in the kernel or not loaded(?) Very confusing.

Due to the above cited problems, I have abandoned exFAT as the external USB drive filesystem and am now trying to use FAT32 (vfat) which should be builtin since the small /boot(?) partition is listed in fstab as type = „vfat“, but without success. Have NOT gotten Max2Play (latest version) to see the MP3 music file contents of the external drive, which is externally powered using it’s own 5vdc supply, when attached to any of the RPi’s 4 USB ports. Also tried external drive without using it’s power supply.

I can use terminal commands (blkid) to discover the external USB drive’s status: /dev/sda1, Label=“FAT32-512GB“ (my correct drive label), UUID=51e2-4430 (correct after reformatting as FAT32), type=vfat, PARTUUID=1fb0946c-01 (reasonable). This has become quite frustrating…. an external FAT32 formatted USB SSD drive, with it’s own powersupply, can not be read even though during RPi boot process linux can recognize important information about the same drive: UUID, label, type=vfat …etc.

My goal was simply to attach a known to be working USB SSD drive holding my MP3 music library to the Max2Play Raspberry Pi-3b thru any of the RPi-3b USB ports so Squeezebox Server could use a locally attached music library. This had worked before a couple years ago using the same USB SSD drive formatted as EXT4. Once attached and configured to automount in fstab (using UUID source label mounted to a local folder…) was able to copy my music library from my Hackintosh over the local network to the RPi-Max2Play. Worked well, played music fine.

This time I wanted to copy my music library directly to the same USB SSD formatted with a filesystem (exFAT or FAT32) that was compatible with MacOS and Max2Play-RPi. Seemed reasonable, however as outlined above I can not get the Max2Play to see the contents of the USB SSD drive formatted as FAT32 at all. My assumption is: if the external USB drive is attached and using /etc/fstab mounted to /mnt/usbdrive/ then I should be able to see the contents of the USB drive by looking in directory /mnt/usbdrive/

FSTAB
Here is my /etc/fstab file:

proc /proc proc defaults 0 0
PARTUUID=ee397c53-01 /boot vfat defaults 0 2
PARTUUID=ee397c53-02 / ext4 defaults,noatime 0 1

##USERMOUNT
UUID=51e2-4430 /mnt/usbdrive vfat defaults,users,nofail,noatime,nodiratime,umask=000 0 0

I created the folder /mnt/usbdrive then, chmod 777 /mnt/usbdrive. Tried various USB cables to attach the external drive to RPi USB2 ports. Nothing allows me to see the contents of the external USB drive. When the drive is plugged into my Hackintosh USB port the entire 220gB MP3 files content of the drive is visible and can be R/W.

A simple USB memory stick formatted FAT32, not an SSD drive, does not work either attached to any of the RPi USB ports. Used the „mount“ command thru VNC and terminal after Max2Play finished booting.

When I made a mistake removing fstab option: „nofail“ the Max2Play RPi-3b would not boot. Had to edit the /etc/fstab file by connecting the Max2Play SDcard to my Synology NAS (linux-OS of course), editing the /etc/fstab file to add „nofail“ and was able to boot the Max2Play once again. I mention this because when I was able to boot into RPi „emergency mode“ no USB keyboard I tried was recognized by the RPi … none. Had to abandon „emergency mode“ since not able to use keyboard input.

Makes me wonder if the Max2Play-OS later in the bootup process has disabled all the USB ports for passing traffic. Early in the boot process the USB ports are active, which is why the OS can see my external drive status info, but later in the boot process the USB ports will not pass traffic across the bus ???? Has this symptom been seen by Max2Play ? I thought there used to be a Max2Play GUI option setting which disabled the USB ports for keyboards and mice if the system was run „headless“ ?

Thank you for reading this long post. I have enjoyed Max2Play-OS for serving music with Squeezebox Server and recommended the product to many friends. However, if I can no longer use an external USB drive with the system, I may have to use an old laptop to run Squeezebox Server (LMS). At least it can mount an external drive or load my music library into internal storage.

Many regards,

— mark early (Seattle, NW corner of Vereinigte Staaten)

UPDATE: Recognizing USB drives seems to be a timing issue. When I leave a simple USB-flash drive formatted FAT32 plugged into a USB port then power-on bootup Max2Play-OS the USB drive’s UUID is displayed correctly by command „sudo blkid“, but it’s contents are not visible either from a manual „mount“ command or from an entry in fstab. However, when the USB-flash-drive is left unplugged… bootup Max2Play-OS …. wait…plug in USB-flash-drive and then manually mount with command „sudo mount /dev/sda1 /mnt/usbstick -o umask=000“ the contents of the usb-flash-drive are correctly visible. This is obviously very inconvenient. Is there a linux/Max2Play-OS configuration setting that will fix this timing issue ?

Thank-you

UPDATE – FINAL

For the benefit of other Max2Play users who experience this external USB drive issue.
On my RPi-3b LMS music server running v2.56 of Max2Play, the contents of a FAT32 external USB-SSD drive was ultimately made available on bootup only by using the following line in /etc/fstab „/dev/sda1 /mnt/usbstick vfat defaults,users,nofail,noatime,nodiratime,umask=000 0 0“. Of course substitute your own mount point (/mnt/usbstick) and mounting options. The important point is I could not use UUID to identify the device and had to use „/dev/sda1“ instead. Even though the UUID for my external USB drive was correct it never worked for me. Also added two instructions in file /etc/rc.local just ahead of the „exit 0“ line:
sleep 20
sudo mount -a

These two instructions added to /etc/rc.local was recommended online by users who also experienced problems mounting USB drives at bootup on RPi systems.