Reply To: raspi not booting – bricked?

18. April 2020 at 12:42 #48548

Hi Heiner,

I hope you are well and can help with my issue. I’m a relative linux noob but have use m2p for the last few years without problem – great software which I prefer to moode, volumio etc. I’m having major problems since updating the packages and kernel yesterday (everything seemed fine) and then tring to install MPS/Ampache which crashed my allo usbridge signature. I got the same message as the OP above when rebooting and trying to connect to the m2p browser via wifi dongle..

loadViewHeader(); // search for Controller and View by Name in URL if (! isset($_GET[‚page‘]) || strpos($_GET[‚page‘], ‚plugin‘) === FALSE) { $pagename = preg_replace(‚=[^0-9a-zA-Z\.]=‘, “, isset($_GET[‚page‘]) ? $_GET[‚page‘] : “); if ($pagename == “) { // get Default Plugin for first Page foreach ($service->plugins[‚plugin‘] as $plugin) { if (isset($plugin[‚default‘]) && $plugin[‚default‘] == 1) { include_once (APPLICATION_PATH . $plugin[‚path‘]); break; } } } } else { // get Plugin by Config… check for Images or other Content if(preg_match(‚=\.(png|jpg|gif|pdf)$=‘, $_GET[‚page‘])){ // just Output Content $file = APPLICATION_PATH . ‚/‘ . $_GET[‚page‘]; ob_clean(); $size = getimagesize($file); header(‚Content-Type: ‚.$size[‚mime‘]); header(‚Content-Length: ‚.filesize($file)); readfile($file); exit; }else{ include_once (APPLICATION_PATH . ‚/‘ . $_GET[‚page‘]); } } $service->loadViewFooter(); ob_flush();

Even after trying several fresh m2p image installs on different SD cards (class 10 / U1 which all worked great before) this message persists when trying certain m2p browser tabs (settings/reboot and filesystem mount) so am unable to configure the system. The others tabs seem to work. Connecting to m2p browser via ethernet doesn’t give the above message but max2play still doesn’t respond as normal – I can’t start squeezlite for example..

Trying to launch … NOT successful Click here to show detailed information
[11:19:24.739588] test_open:384 playback open error: No such device
[11:19:24.739789] output_init_common:382 unable to open output device

I’ve also tried re-installing moode audio but this no longer works either. So I’m worried I’ve somehow broken the allo. I did have to throw away the m2p pre-loaded sd card I received from you with the allo usb sig so I’m wondering if this unit keeps corrupting these cards somehow! Any help appreciated!