Reply To: [BeoCreate Noise/Knacken Fix] GPIO access possible via Max2Play?

Max2Play Home 2016 (en) Forums SD-Card Imaging and getting started [BeoCreate Noise/Knacken Fix] GPIO access possible via Max2Play? Reply To: [BeoCreate Noise/Knacken Fix] GPIO access possible via Max2Play?

6. Mai 2018 at 22:19 #35525

Hi guys,
I have the same problem. Adding the gpio commands in rc.local does not avoid the annoying noise.
I’m a Linux noob but plan is to implement the idea of Spartan117. I tried to delay the execution of the gpio commands like this:
– I created a new script /etc/MuteDisable which contains

  #!/bin/sh
  # shell script to disable mute
  sleep 10
  gpio mode 2 out
  gpio write 2 0

– I tried executing the script directly from the command line and it works (after 10 seconds the sound it turned on)
– In /etc/rc.local I added the line (before exit 0 😉 )
/etc/MuteDisable
But this does not seem to work.
Since I am noob I think the problem is caused by this incorrect line.

Can anybody help me?

Edit 7 May 2018: I found the mistake. I did not grant execution rights for the script. 🙁
chmod 755 /etc/MuteDisable
did the job. Now it works fine!

Cheers MaxAy

  • This reply was modified 2 years, 6 months ago by  MaxAy.
  • This reply was modified 2 years, 6 months ago by  MaxAy.