Reply To: Filesystem mounts, but LMS doesn't see my music!

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Filesystem mounts, but LMS doesn't see my music! Reply To: Filesystem mounts, but LMS doesn't see my music!

1. März 2018 at 1:20 #34152

Hi Heiner

First – thank you very much for trying to help! It’s greatly appreciated. Let me respond to your questions directly:

Here’s what your wrote:
Let me first make sure I get the situation correctly:
– You have a share with the files of a USB HDD attached to an Apple NAS (Correct)
– You used our filesystem mount menu to add the share with HDD’s files on the Apple NAS to your Pi
(also correct)
– You selected the path with the files in the LMS but the files are not found (correct again, examples below)
– The files are found in a different setup with a different NAS (?)
(I’ve got a similar system running just fine at work; and, the system at home that has me pulling out my hair worked just fine prior to an extended absence… when I rebooted upon return, the files could not be found… making this even more frustrating).

Ideas:
– Make sure the format of HDD which is correct for the Apple product is also working with RPi (The HDD is formatted explicitly for the Apple Airport Extreme, and the files can be seen on my Windows 10 laptop. Also, as mentioned, it was working fine with the RPI/M2P/Logitec setup).
– Try connecting the HDD directly to the Pi and create a SambaShare on the path to share it with the rest of the network
(interesting idea, but I’m not familiar with Linux, and unsure as to how to drop out of the M2P operating system into Linux. Assuming that the RPi has enough horsepower to run the filesystem and M2P at the same time, though, that’s an interesting idea).
– Make sure your files and folders of music do not have any special rights or formats to rule this out as a source of error (I will double check).

Here’s the filesystem mount in M2P:

Filesystem – mount network paths (Samba or NFS)
Path: //192.168.0.2/TIMS-AIRPORT-EX/music??????/music/

Mountpoint:/mnt/music/

Type: cifs

Options:user=null,password=music,sec=ntlm,iocharset=utf8

And here’s the path in LMS:

Media Library Name: Music

Media Folders
Folder: /mnt/share/music

Again, Heiner, I’m grateful for any ideas or help. Thank you!

Dave