Reply To: [SOLVED] Cannot upgrade to Kodi newer than 14.

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI [SOLVED] Cannot upgrade to Kodi newer than 14. Reply To: [SOLVED] Cannot upgrade to Kodi newer than 14.

14. Dezember 2016 at 15:25 #24875

Hi sadglad,
The current default Kodi version on our images is 15.2-2.
Maybe you still have a wheezy-based image. We upgraded to jessie lite some months ago. Please try burning a new image to get a newer version of Kodi from the first boot.