Reply To: M2P 2.34/2.36, RPi 3 and Wolfson/Cirrus card.

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI M2P 2.34/2.36, RPi 3 and Wolfson/Cirrus card. Reply To: M2P 2.34/2.36, RPi 3 and Wolfson/Cirrus card.

11. October 2016 at 1:30 #23363

Hi mike and Stefan,

Mike, thanks for your reply. Seems 2.37 fixes things.

Stefan, that is great news. Unfortunately, “the current version of Max2Play (version 2.37) uses a newer Kernel that fits the latest Max2Play-Image and uses a renamed Device Tree Overlay for the card.” is all a bit above me technically, and that is why I love your M2P, it works and lets me do things with a RPi that I wouldn’t be able to without it. Maybe it is time or me to try and learn about DTO’s and Kernels.

I have updated to 2.37 and all is still working, but I noticed under debug on the Settings/Reboot page that I am on Kernel 4.1.13, is this okay or should I update to Kernel 4.4.y that you mention below? How would I do this? Re-select the Wolfson/Cirrus card under Raspberry Settings and reboot?

Debug info: Linux xxxx 4.1.13-v7+ #1 SMP PREEMPT Sat Nov 21 12:39:03 CET 2015 armv7l GNU/Linux

I still see at the bottom of the Raspberry Settings page, ‘Upgrade to latest Kernel (breaks Wolfson Audio cards!):’ Does this still apply, or this how to get to Kernel 4.4.y?

Thanks.
Simon