Reply To: Big problems from a small bug in v2.31

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Big problems from a small bug in v2.31 Reply To: Big problems from a small bug in v2.31

6. July 2016 at 9:12 #21234

Hi Martin,

It looks like there’s 2 different issues here and I don’t think they’re related:

sudo: unable to resolve host raspberry Timed out
It seems the bug is only fixed partially in v2.32 and you “triggered” it again by renaming your player to “raspberry”.
I bet that since changing the name the webinterface became slow on certain actions. Naming it back to max2play should resolve that part of your issue until the bug is 100% fixed.

The core issue is that when the name in /etc/hostname doesn’t match with an entry in /etc/hosts you get the slowness caused by the “sudo: unable to resolve host <your_player_name>” error. In v2.31 /etc/hostname contained “max2play” while /etc/hosts had “raspberry”. They fixed it in v2.32 by changing the /etc/hostname entry to “max2play” but it looks like that file doesn’t get updated when you rename your player.

Password for root@//192.168.0.22/: Retrying with upper case share name mount error(6)
I’m still relatively new to max2play and haven’t tried any mounting yet as I have no need for it yet.
I suggest you give more info on what system you’re trying to mount from like the Operating System, what protocol and if you’re able to mount it from other (non max2play) systems.
Maybe start a new topic on it so you get a broader audience and attract people with more experience on mounting issues.

Cheers,
OneArmedBandit