Reply To: Squeezelite and shairport together on "blocking" DAC

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI Squeezelite and shairport together on "blocking" DAC Reply To: Squeezelite and shairport together on "blocking" DAC

30. November 2015 at 22:42 #17069

Hi, I have a somewhat easier setup, but it still does not work at all.

It is a Pi 1 B+ model with a HifiBerry compatible I2S soundcard.
I downloaded and installed the M2P HifiBerry image to an 8GB card and did the initial setup in M2P:
1) enter email adress
2) install M2P update
3) set up soundcard
4) mounted network drive (all ethernet)
5) added libs to LMS
6) installed/activated Shairtunes2 plugin

Squeezeplug is running fine, radio stations work fine and the LMS settings/plugin page shows the Shairtunes2 plugin as active.

From reading existing documentation it is not clear to me whether this setup as such would already be good enough to enable airplay. Because when looking into the airplay menu on the iPhone (same network of course), no airplay capable device is detected. (I know that the hardware can do this, with the RuneAudio setup airplay to the same hardware config was not an issue).

So I tried to launch the Shairport process from the Audioplayer tab. It claims to launch and then successfully having started a proc ID. But when navigating away and back to the audioplayer tab it is either not running (or showing a higher process ID number, in case auto start is activated). In its settings I have tried various soundcard options and also the automatic audio switch (filling in the M2P’s IP address).

None of these actions would make airplay available in the network.

I guess both processes (Shairtunes and Shairport) are needed? If so, I assume the Shairport process should remain as is instead of crashing and starting over all the time, which is probably happening now. Any hints how to investigate and fix this?

Interestingly, I had the same trouble with a different Raspi using a non-hifiberry-M2P image with an USB-Soundcard, some month ago, but gave up fixing it. But now that both machines are not working, this is too bad…

Any help is greatly appreciated!
Best, Andreas.