Reply To: [FIX INSIDE] Pi3 and HiFiBerry Amp 2 produces no sound with Max2Play

27. Oktober 2017 at 11:37 #32148

Hi guys,

Sorry about the confusion.

The driver is not yet added to the Raspberry Settings overview. Selecting it in the HiFiBerry Plugin is the recommend way to go.

After reboot you should get the right drivers. In Audioplayer menu, make sure that Squeezelite is running successfully with a process and that “sysdefault – snd_rpi_hifiberry_dacplus, – Default Audio Device, CARD=sndrpihifiberry” is selected.

The one issue I experienced while setting it up, is that we now automatically set the hardware volume control in the command line options (in Squeezelite’s advanced options) to „hw:0“ which only works with the built-in audio is deactivated. You can do this in the Raspberry Settings. If you do not have a premium license or do not do deactivate the built-in audio, you either:

Option 1:
Remove the command line options from Squeezelite’s Advanced Options and click „save“
-> NO Hardware Volume Control anymore!

Option 2:
Change the hw:0 to hw:1 OR deactivate build in audio in the Raspberry Settings
-> Hardware Volume Control remains

Thanks for pointing us towards this issue, we will find the best fix for this as soon as possible and I will make sure everybody encountering this gets the solution they need.

For now, these options are your best bet. Please let me know whether you would prefer Hardware Volume Control to be set right after selection, or whether you would rather want it to be optionally available as a later addition?

  • This reply was modified 3 years, 8 months ago by  Heiner.