Reply To: [SOLVED] Spotify Connect Auto Start appears to be failing

Max2Play Home 2016 (en) Forums Max2Play Add-ons [SOLVED] Spotify Connect Auto Start appears to be failing Reply To: [SOLVED] Spotify Connect Auto Start appears to be failing

15. Oktober 2017 at 3:04 #31899

Hallo,
erst Mal vielen Dank für die Antwort. Leider habe ich wenig Zeit und konnte erst jetzt wieder weiter probieren.

Ich bin nun noch mal komplett von vorne angefangen und wie folgt vorgegangen.

-Max2Play Image neu runtergeladen (Version 2.44) und auf SD-Karte kopiert
-Mail Adresse zum aktivieren eingetragen
-Sprache auf Deutsch/Deutschland geändert
-Spotify Connect Plugin heruntergeladen und installiert
-Haken bei Autostart gesetzt
– Zugangsdaten für Spotify eingetragen
-Im Menü Audioplayer die Autostart Haken bei Squeezelite und Shairport entfernt
-Im Menü WLAN & LAN den Haken bei Aktiviere WPS beim Booten entfernt
-Spotify Plugin gestartet (läuft)
-Auf die USB- Soundkarte habe ich erst mal verzichtet um diese als Fehlerquelle aus zu schließen.

-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft NICHT!!!
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart durch Trennung der Stromversorgung
-Spotify Connect Service läuft NICHT!!!
-Neustart durch Trennung der Stromversorgung
-Spotify Connect Service läuft NICHT!!!
-Neustart durch Trennung der Stromversorgung
-Spotify Connect Service läuft NICHT!!!
-Neustart durch Trennung der Stromversorgung
-Spotify Connect Service läuft NICHT!!!
-Neustart durch Trennung der Stromversorgung
-Spotify Connect Service läuft NICHT!!!
-Neustart durch Trennung der Stromversorgung
-Spotify Connect Service läuft NICHT!!!
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart über Menü Einstellungen/Reboot
-Spotify Connect Service läuft
-Neustart durch Trennung der Stromversorgung
-Spotify Connect Service läuft NICHT!!!

Sieht also so aus als würde das Problem hauptsächlich auftreten, wenn man die Stromversorgung trennt. Allerdings meine ich das, bevor ich das Image neu aufgespielt habe, der Service hin und wieder auch gestartet ist obwohl der Raspberry vorher stromlos war.

Hier noch mal die DEBUG Info:

#### Librespot Output ####
INFO:librespot: librespot cc9dba8 (2017-03-26). Built on 2017-07-17. Build ID: 8zQE3Bpb
WARN:librespot::apresolve: Failed to resolve Access Point: HTTP error
WARN:librespot::apresolve: Using fallback „ap.spotify.com:80“
INFO:librespot::session: Connecting to AP „ap.spotify.com:80“
thread ‚main‘ panicked at ‚called Result::unwrap() on an Err value: Error { repr: Custom(Custom { kind: Other, error: StringError(„failed to lookup address information: Name or service not known“) }) }‘, /checkout/src/libcore/result.rs:859
note: Run with RUST_BACKTRACE=1 for a backtrace.

#### Librespot Command Line Options ####
error: Required option ’name‘ missing.
Usage: /opt/spotifyconnect/librespot [options]

Options:
-c, –cache CACHE Path to a directory where files will be cached.
–disable-audio-cache
Disable caching of the audio data.
-n, –name NAME Device name
-b, –bitrate BITRATE
Bitrate (96, 160 or 320). Defaults to 160
–onstart PROGRAM
Run PROGRAM when playback is about to begin.
–onstop PROGRAM
Run PROGRAM when playback has ended.
-v, –verbose Enable verbose output
-u, –username USERNAME
Username to sign in with
-p, –password PASSWORD
Password
–disable-discovery
Disable discovery mode
–backend BACKEND
Audio backend to use. Use ‚?‘ to list options
–device DEVICE Audio device to use. Use ‚?‘ to list options
–mixer MIXER Mixer to use

Das Spotty Plugin habe ich schon auf meinem Squeezebox Server laufen.
Ich bekomme es allerdings nicht hin das dieses Plugin in der Spotify App als „verfügbares Gerät“ angezeigt wird.
In dem link von dir steht ja:

„you can set the checkmark for Spotify Connect in the Squeezebox Server settings under “Spotty Spotify for Squeezebox” in the “player” tab“

Mit „Player Tab“ ist wohl eher „Plugin Tab“ gemeint, oder nicht?
Dort kann ich aber nirgends einen Haken für Spotify Connect setzen. Ich habe Version 1.9.4 installiert. Ist das noch die aktuelle Version?

Mein Ziel ist es in meiner Gartenhütte einen Raspberry zu installieren mit dem ich sowohl auf den Squeezebox Server als auch auf Spotify zugreifen kann. Spotify würde ich gerne via Spotify Connect über die original App bedienen.

Gruß
Aufschlagzuender