Reply To: No support for Audiophonics I-Sabre DAC ES9023 TCXO ? :(

Max2Play Home 2016 (en) Forums Max2Play on Raspberry PI No support for Audiophonics I-Sabre DAC ES9023 TCXO ? :( Reply To: No support for Audiophonics I-Sabre DAC ES9023 TCXO ? :(

1. December 2016 at 20:58 #24475

Hi JCU,

Thanks for all your useful hints. I have also tried several platforms and HW configurations. From MPD to PiCore.

I am really happy that M2P will offer support for Audiophonics !!!
As for my experience with M2P … hummm how to start?

Well let’s put it this way, I was seduced by the capabilities that seem superior to piCore, especially the integration of Kodi as I also use it.

Unfortunately despite your help I need to go back to piCore, before explaining why, Let me describe my set up.

I use a Wyred4Sound DAC2 equipped with 9018 ESS Sabre DAC a 9018 ESS Sabre DAC

https://wyred4sound.com/products/dacs/dac-2-series

with input of I2S over GPIO using a HDMI connector and cable. I use a HDMI output module bought at Audiophonics

http://www.audiophonics.fr/en/interfaces/audio-gd-diy-kit-i2s-to-hdmi-output-module-p-9347.html

The set ups is similar to:

http://www.psaudio.com/forum/directstream-all-about-it/directstream-i2s-input/

So ….

With piCore the play is smooth using Generic I2S and hw:CARD=sndrpihifiberry
Hi resolution files play perfect and the whole thing is stable. I use piCore 2.6 since the 3.02 version produces a horrible crackling when switching from 44.1 KHz to 96KHz.

With your help I managed to get the sound out but could not manage to transfer volume control to the DAC wih -o hw:0 –V Digital

It took me a while to figure out the output of a mixer which was:

Simple mixer control ‘PCM’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback -10239 – 400
Mono: Playback 100 [97%] [1.00dB] [on]

Then I realized that I had to replace Digital for PCM and tried -o hw:0 –V PCM … but did not work

I tried the option on LMS -> Settings -> player -> Audio -> Volume Control -> Output level is fixed at 100%
… and it worked !! (I wonder what the difference is with the transfer with –o hw:0 –V Digital

Then I tried to play Hi-Res files and …. After a few seconds and horrible crackling, the play back simply stops >:-(((

No way to get it back. The output of a mixer was

Simple mixer control ‘PCM’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback -10239 – 400
Mono: Playback -25 [96%] [-0.25dB] [on]

The difference is the Mono: line where I figured that 96% is the volume level but still do not know that the other mean

I then reinstalled from scratch but the problem is still there, no Hi-Res play

Bottom line …. I am back to piCore 2.6 with a license M2P I do not use

The output or piCore amixer is

Simple mixer control ‘PCM’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback -10239 – 400
Mono: Playback -2000 [77%] [-20.00dB] [on]

Where the Mono Line is completely different

@M2P team: It would be great if there would be a I2S generic support and help to figure out the best parameters